summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-08-30 11:35:27 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-08-30 11:35:27 +0200
commite42da6890579c23e639725d00d2b045f101e88c1 (patch)
treead883cde8b2003a163413b154688641f1065f2c0 /dev-python/awscli/awscli-1.10.59.ebuild
parentdev-python/astroid: Bump (diff)
downloadgentoo-e42da6890579c23e639725d00d2b045f101e88c1.tar.gz
gentoo-e42da6890579c23e639725d00d2b045f101e88c1.tar.bz2
gentoo-e42da6890579c23e639725d00d2b045f101e88c1.zip
dev-python/awscli: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/awscli/awscli-1.10.59.ebuild')
-rw-r--r--dev-python/awscli/awscli-1.10.59.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/awscli/awscli-1.10.59.ebuild b/dev-python/awscli/awscli-1.10.59.ebuild
new file mode 100644
index 000000000000..f1631b5ae3ce
--- /dev/null
+++ b/dev-python/awscli/awscli-1.10.59.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="http://pypi.python.org/pypi/awscli"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/botocore[${PYTHON_USEDEP}]
+ <=dev-python/colorama-0.3.3[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ <=dev-python/rsa-3.5.0[${PYTHON_USEDEP}]
+ dev-python/s3transfer[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "