summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-03 06:48:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-03 07:37:37 +0200
commit9b8ff1a4e9d1d0ab7218272855e31aba44e9655c (patch)
tree01c0c8e5779a3116e4c5d6211f3cea0e56fef55a /dev-python/awxkit
parentdev-python/autobahn: Bump to 22.5.1 (diff)
downloadgentoo-9b8ff1a4e9d1d0ab7218272855e31aba44e9655c.tar.gz
gentoo-9b8ff1a4e9d1d0ab7218272855e31aba44e9655c.tar.bz2
gentoo-9b8ff1a4e9d1d0ab7218272855e31aba44e9655c.zip
dev-python/awxkit: Bump to 21.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/awxkit')
-rw-r--r--dev-python/awxkit/Manifest1
-rw-r--r--dev-python/awxkit/awxkit-21.1.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/awxkit/Manifest b/dev-python/awxkit/Manifest
index cea8cc3cc958..82d648df2e64 100644
--- a/dev-python/awxkit/Manifest
+++ b/dev-python/awxkit/Manifest
@@ -1 +1,2 @@
DIST awxkit-21.0.0.gh.tar.gz 16493147 BLAKE2B 9b89f9f6f2e231efcde0edeb7d39a1b328b9b534a38663a2463f974028ce96aa13677d8e14d4b4a55fd3de252d5e53dbab2d104e018ad60eaca1ddb1b7bf937c SHA512 e100359eb9be184924c9b562473dd23dcfddf270e72f2f0fc1f71f8774dc1d3fbfce6b365f13ecffe20b25b116690fcca504d373663c497e74d2d1185b98f01f
+DIST awxkit-21.1.0.gh.tar.gz 16516204 BLAKE2B 2891244e7dcb0aef7b2053713c4479b94528a69f1225a77c46243cb293ebfa2e86d59939bc906223e598c34a322a726c9b3f5fb9aa7859191385f9c15bae57a0 SHA512 2e2ff1ae5a1893e3ba464ff0ab3c5e98b7d0711c3ba1512b8a8f89e55385ab85df9623b23d6a81b2a800b0b184de1ef82fd23a655173fcbcebb1160e9eef973c
diff --git a/dev-python/awxkit/awxkit-21.1.0.ebuild b/dev-python/awxkit/awxkit-21.1.0.ebuild
new file mode 100644
index 000000000000..f63cc6bc217b
--- /dev/null
+++ b/dev-python/awxkit/awxkit-21.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command line interface for Ansible AWX"
+HOMEPAGE="https://github.com/ansible/awx"
+SRC_URI="https://github.com/ansible/awx/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/awx-${PV}/awxkit"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+ sed -e 's|websocket-client==[[:digit:]\.]*|websocket-client|' \
+ -e "/'clean'/d" \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}