summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-05-11 07:28:19 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-12 19:39:36 +0800
commitb8c237439db49d7d95deed40905b0b1d56a76a50 (patch)
tree3a2f5675d3b95851083e186d0e4d82b1834764d0 /dev-python/babelfish/babelfish-0.5.5-r1.ebuild
parentdev-python/babelfish: remove old (diff)
downloadgentoo-b8c237439db49d7d95deed40905b0b1d56a76a50.tar.gz
gentoo-b8c237439db49d7d95deed40905b0b1d56a76a50.tar.bz2
gentoo-b8c237439db49d7d95deed40905b0b1d56a76a50.zip
dev-python/babelfish: revbump to 0.5.5-r1
Bump EAPI to 6, fix deps. Update 9999 ebuild accordingly. Package-Manager: portage-2.2.28 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/babelfish/babelfish-0.5.5-r1.ebuild')
-rw-r--r--dev-python/babelfish/babelfish-0.5.5-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/babelfish/babelfish-0.5.5-r1.ebuild b/dev-python/babelfish/babelfish-0.5.5-r1.ebuild
new file mode 100644
index 000000000000..9425901924f9
--- /dev/null
+++ b/dev-python/babelfish/babelfish-0.5.5-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with countries and languages"
+HOMEPAGE="https://github.com/Diaoul/babelfish https://pypi.python.org/pypi/babelfish"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ esetup.py test
+}