summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 19:00:14 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 19:36:32 +0200
commit39cca28f995e904abf9c526dfa87e577152ec45c (patch)
tree582c326e5c102a633aefffa390c5e02dc927ac7d /dev-python/backcall
parentx11-libs/libXxf86misc: Remove (diff)
downloadgentoo-39cca28f995e904abf9c526dfa87e577152ec45c.tar.gz
gentoo-39cca28f995e904abf9c526dfa87e577152ec45c.tar.bz2
gentoo-39cca28f995e904abf9c526dfa87e577152ec45c.zip
dev-python/backcall: Port to py3.9, enable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/backcall')
-rw-r--r--dev-python/backcall/backcall-0.1.0-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/backcall/backcall-0.1.0-r1.ebuild b/dev-python/backcall/backcall-0.1.0-r1.ebuild
index 3168ccb468da..4cdb8b03978b 100644
--- a/dev-python/backcall/backcall-0.1.0-r1.ebuild
+++ b/dev-python/backcall/backcall-0.1.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -13,3 +13,5 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest