summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-10 10:16:13 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-10 11:54:09 +0100
commit88bd7178c17314c9945b4f8fccf04b9292fa8b19 (patch)
tree9665382c9a5fbb208de06e77ac110407875444dd /dev-python/backports-abc/backports-abc-0.4.ebuild
parentvirtual/python-asyncio: Propagate KEYWORDS (diff)
downloadgentoo-88bd7178c17314c9945b4f8fccf04b9292fa8b19.tar.gz
gentoo-88bd7178c17314c9945b4f8fccf04b9292fa8b19.tar.bz2
gentoo-88bd7178c17314c9945b4f8fccf04b9292fa8b19.zip
dev-python/backports-abc: New package written by me
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/backports-abc/backports-abc-0.4.ebuild')
-rw-r--r--dev-python/backports-abc/backports-abc-0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/backports-abc/backports-abc-0.4.ebuild b/dev-python/backports-abc/backports-abc-0.4.ebuild
new file mode 100644
index 000000000000..772b67d9ea2c
--- /dev/null
+++ b/dev-python/backports-abc/backports-abc-0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Backport of Python 3.5's 'collections.abc' module"
+HOMEPAGE="https://github.com/cython/backports_abc https://pypi.python.org/pypi/backports_abc/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+# https://github.com/cython/backports_abc/issues/4
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" "${PYTHON}" tests.py || die "tests failed with ${EPYTHON}"
+}