summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/backports-lzma
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/backports-lzma')
-rw-r--r--dev-python/backports-lzma/Manifest1
-rw-r--r--dev-python/backports-lzma/backports-lzma-0.0.3.ebuild38
-rw-r--r--dev-python/backports-lzma/metadata.xml9
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/backports-lzma/Manifest b/dev-python/backports-lzma/Manifest
new file mode 100644
index 000000000000..e44ec1c3aaa4
--- /dev/null
+++ b/dev-python/backports-lzma/Manifest
@@ -0,0 +1 @@
+DIST backports.lzma-0.0.3.tar.gz 33848 SHA256 bac58aec8d39ac3d22250840fb24830d0e4a0ef05ad8f3f09172dc0cc80cdbca SHA512 a653b61d1e45de73ac13845127fecd97e84872c453be9e090ba2d6d2ff6187817ab980e36c1961f0a66bb9a660bb716fc7679b5317a4ff41db42156024847f45 WHIRLPOOL 33eb3c8b1c9aa8d4beabdc52247cea4b0ad2913989a2b508f71073a7a6b8dd9b6260339233f78d8e8f28476c48242076b3a95b427155f0605336e17b79e0d9ee
diff --git a/dev-python/backports-lzma/backports-lzma-0.0.3.ebuild b/dev-python/backports-lzma/backports-lzma-0.0.3.ebuild
new file mode 100644
index 000000000000..8d3824084c13
--- /dev/null
+++ b/dev-python/backports-lzma/backports-lzma-0.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Backport of Python 3.3's lzma module for XZ/LZMA compressed files"
+HOMEPAGE="https://github.com/peterjc/backports.lzma/ http://pypi.python.org/pypi/backports.lzma/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-arch/xz-utils
+ dev-python/backports[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" "${PYTHON}" test/test_lzma.py || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ # main namespace provided by dev-python/backports
+ rm "${BUILD_DIR}"/lib/backports/__init__.py || die
+ rm -f backports/__init__.py || die
+
+ distutils-r1_python_install
+}
diff --git a/dev-python/backports-lzma/metadata.xml b/dev-python/backports-lzma/metadata.xml
new file mode 100644
index 000000000000..1780f771218c
--- /dev/null
+++ b/dev-python/backports-lzma/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">peterjc/backports.lzma</remote-id>
+ <remote-id type="pypi">backports.lzma</remote-id>
+ </upstream>
+</pkgmetadata>