summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Saboya <saboya@users.noreply.github.com>2017-01-27 18:26:43 -0200
committerDavid Seifert <soap@gentoo.org>2017-02-04 22:31:48 +0100
commit410f870798000d90550907c1d7554862be797708 (patch)
tree8bef0ce3ebac08819da1133e23d392505dac509f /dev-python/backports-shutil_which
parentdev-python/pickleshare: Version bump to 0.7.4 (diff)
downloadgentoo-410f870798000d90550907c1d7554862be797708.tar.gz
gentoo-410f870798000d90550907c1d7554862be797708.tar.bz2
gentoo-410f870798000d90550907c1d7554862be797708.zip
dev-python/backports-shutil_which: New package
Closes: https://github.com/gentoo/gentoo/pull/3687
Diffstat (limited to 'dev-python/backports-shutil_which')
-rw-r--r--dev-python/backports-shutil_which/Manifest1
-rw-r--r--dev-python/backports-shutil_which/backports-shutil_which-3.5.1.ebuild33
-rw-r--r--dev-python/backports-shutil_which/metadata.xml12
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/backports-shutil_which/Manifest b/dev-python/backports-shutil_which/Manifest
new file mode 100644
index 000000000000..922c6cbaa796
--- /dev/null
+++ b/dev-python/backports-shutil_which/Manifest
@@ -0,0 +1 @@
+DIST backports.shutil_which-3.5.1.tar.gz 3020 SHA256 dd439a7b02433e47968c25a45a76704201c4ef2167deb49830281c379b1a4a9b SHA512 066096f6cde0d245f2a8ff27b8e99bcec7088a2c9667c6b3dc73dd8866ea98acfb32c63222e8349eb906460b8ade864b18cf88a627070e20e28d5c00aded3ae4 WHIRLPOOL d5d57ecc6a5d37027079576d6dd1fe405eaba60e07fb7ba83852f23379de398ce8e5fc4c458e4a63860cae8c1e63b19c56fab4817efe7cdee2e256bffe0084ed
diff --git a/dev-python/backports-shutil_which/backports-shutil_which-3.5.1.ebuild b/dev-python/backports-shutil_which/backports-shutil_which-3.5.1.ebuild
new file mode 100644
index 000000000000..cd35b9726181
--- /dev/null
+++ b/dev-python/backports-shutil_which/backports-shutil_which-3.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="backports.shutil_which"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Backport of shutil.which from Python 3.3"
+HOMEPAGE="https://pypi.python.org/pypi/backports.shutil_which/ https://github.com/minrk/backports.shutil_which"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/backports[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_install() {
+ distutils-r1_python_install
+
+ # main namespace provided by dev-python/backports
+ rm "${D}$(python_get_sitedir)"/backports/__init__.py* || die
+}
diff --git a/dev-python/backports-shutil_which/metadata.xml b/dev-python/backports-shutil_which/metadata.xml
new file mode 100644
index 000000000000..bb2287b53848
--- /dev/null
+++ b/dev-python/backports-shutil_which/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">backports.shutil_which</remote-id>
+ <remote-id type="github">minrk/backports.shutil_which</remote-id>
+ </upstream>
+</pkgmetadata>