summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-24 00:15:34 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-24 00:30:27 +0100
commit3f6eefe323be0e7d3820d44e4d7c5e32092ad926 (patch)
tree6f8791982bf47e5df38da6b3e8763e7d733e5fa4 /dev-python/backrefs
parentdev-python/pygit2: Bump to 1.5.0 (diff)
downloadgentoo-3f6eefe323be0e7d3820d44e4d7c5e32092ad926.tar.gz
gentoo-3f6eefe323be0e7d3820d44e4d7c5e32092ad926.tar.bz2
gentoo-3f6eefe323be0e7d3820d44e4d7c5e32092ad926.zip
dev-python/backrefs: Bump to 5.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/backrefs')
-rw-r--r--dev-python/backrefs/Manifest1
-rw-r--r--dev-python/backrefs/backrefs-5.0.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/backrefs/Manifest b/dev-python/backrefs/Manifest
index acaa44244206..aae0beacb852 100644
--- a/dev-python/backrefs/Manifest
+++ b/dev-python/backrefs/Manifest
@@ -1,3 +1,4 @@
DIST backrefs-4.5.0.tar.gz 5995247 BLAKE2B ce3d33b91ab307811e555689a2ece0ba47e53d8245fd4fa367156a76893c5ca342cb47d014a3c94c6f30ebb32487fb36975a2fa6c7acf0a626305d05e0d80048 SHA512 c1e30a78c2e7a86efce1670000612b6450b6cae78f8c799cec6832aa88e4145fee6ffc3e1b8c54b55091f7c21ea4b09c1ee36af852bb51973434b593273e04a8
DIST backrefs-4.6.tar.gz 5995313 BLAKE2B 5bc6c6b496dc74f1a73a155b7825a134ef84458c0396bc2e678e93432c37b1355f782331fce978dee1c9968cc683c3821ae8975bbd20d4e19896277a6bf5b0c8 SHA512 96aeba6aab34ea14a48c430b00e242b3468054cfccfdab00a66071434e65df4378caffc32f47eded48b5054f7bfcd0caaa04bf103b9fa282ddb5c6119c46f88f
+DIST backrefs-5.0.1.tar.gz 4120179 BLAKE2B 2cd8fb84c7e416be330cb9afdb894f6f8574b66698acc1d63abae8ff5bfcccd4bf29b724dcf2a25a637ea0fde46865b18a5ff1bfbff955a01798037752dc3d97 SHA512 e2212bd7dce017308fa558ccfe7faf617ed6107523db8b2e4a3ad7b60aa1d7aabdaea2632abd6a3f1f022eac949d7036a7afe522b5f086ef1888a0e67e834894
DIST backrefs-5.0.tar.gz 4120151 BLAKE2B 350b59c31d75b18df249f7bbd1625c2183182581dbf4b473c6fe58cbb7722b71a260769fd918d992e5aadfd8f4e848449609de2d307e1dd95aeb6125d5ac7a03 SHA512 c1b7f70f02171535609e3abfb4ad38174b63b935b4f904759069cc8cf9ea6c8fbeeefedc2a150c2d9eafc70ec29a4c5915809d7a8931e0a5af7e6df1ff5b136d
diff --git a/dev-python/backrefs/backrefs-5.0.1.ebuild b/dev-python/backrefs/backrefs-5.0.1.ebuild
new file mode 100644
index 000000000000..72b44d4b44cf
--- /dev/null
+++ b/dev-python/backrefs/backrefs-5.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ ~dev-python/mkdocs_pymdownx_material_extras-1.0.7
+ dev-python/mkdocs-minify-plugin
+ dev-python/mkdocs-material
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wrapper around re or regex that adds additional back references"
+HOMEPAGE="
+ https://github.com/facelessuser/backrefs/
+ https://pypi.org/project/backrefs/
+"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}