summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:51:25 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:51:25 +0100
commit8cbe96240fe7ab8bdb52fedca454bd158ea03556 (patch)
treeb8322664a648164d755175a0d240cb2ec609c542 /dev-python/bandit/bandit-1.0.1.ebuild
parentdev-python/backports-abc: Remove old (diff)
downloadgentoo-8cbe96240fe7ab8bdb52fedca454bd158ea03556.tar.gz
gentoo-8cbe96240fe7ab8bdb52fedca454bd158ea03556.tar.bz2
gentoo-8cbe96240fe7ab8bdb52fedca454bd158ea03556.zip
dev-python/bandit: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/bandit/bandit-1.0.1.ebuild')
-rw-r--r--dev-python/bandit/bandit-1.0.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/bandit/bandit-1.0.1.ebuild b/dev-python/bandit/bandit-1.0.1.ebuild
deleted file mode 100644
index d6617bf5f6d4..000000000000
--- a/dev-python/bandit/bandit-1.0.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="A security linter from OpenStack Security"
-HOMEPAGE="https://openstack.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
- >=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
- <dev-python/hacking-0.10[${PYTHON_USEDEP}]
- >=dev-python/mock-1.2[${PYTHON_USEDEP}]
- >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/git-python-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]"
-
-python_test() {
- testr init
- testr run || die
-}