summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-01-12 12:01:26 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-01-12 12:02:14 -0600
commit7dae0b38e7763753a6bd1db165c2ee6b9254b83e (patch)
treece16b9da89aaa60a8f8a55ad01bd4ee7c27013e4 /dev-python/bandit/bandit-1.4.0.ebuild
parentx11-apps/copyq: remove 2.5.0 (diff)
downloadgentoo-7dae0b38e7763753a6bd1db165c2ee6b9254b83e.tar.gz
gentoo-7dae0b38e7763753a6bd1db165c2ee6b9254b83e.tar.bz2
gentoo-7dae0b38e7763753a6bd1db165c2ee6b9254b83e.zip
dev-python/bandit: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/bandit/bandit-1.4.0.ebuild')
-rw-r--r--dev-python/bandit/bandit-1.4.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/bandit/bandit-1.4.0.ebuild b/dev-python/bandit/bandit-1.4.0.ebuild
new file mode 100644
index 000000000000..f6911ad3fb01
--- /dev/null
+++ b/dev-python/bandit/bandit-1.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://openstack.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.4.5[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/git-python-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.17.1[${PYTHON_USEDEP}]"
+
+python_test() {
+ testr init
+ testr run || die
+}