summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-11-12 21:47:24 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-11-12 21:49:58 +0200
commit63fe55de2af709e5e360e8e638d47866fbabecbd (patch)
tree415d0bba5a8d6738154e11a01dd2b8a186ea45a4 /dev-python/bandit
parentgnome-base/gnome-settings-daemon: backport meson fix (diff)
downloadgentoo-63fe55de2af709e5e360e8e638d47866fbabecbd.tar.gz
gentoo-63fe55de2af709e5e360e8e638d47866fbabecbd.tar.bz2
gentoo-63fe55de2af709e5e360e8e638d47866fbabecbd.zip
dev-python/bandit: fix prepare calls
Fixes: 20c7c7acd861c0a462c611702587993a004faf14 Closes: https://bugs.gentoo.org/802564 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/bandit-1.7.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/bandit/bandit-1.7.0.ebuild b/dev-python/bandit/bandit-1.7.0.ebuild
index 917f337ff285..c30765e91f50 100644
--- a/dev-python/bandit/bandit-1.7.0.ebuild
+++ b/dev-python/bandit/bandit-1.7.0.ebuild
@@ -37,9 +37,9 @@ RDEPEND="
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]"
-python_prepare() {
+src_prepare() {
sed -i 's/yaml.load/yaml.safe_load/g' tests/unit/formatters/test_yaml.py || die
- distutils-r1_python_prepare_all
+ distutils-r1_src_prepare
}
python_test() {