summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 21:57:24 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 22:06:07 +0200
commit6922e71e8dcdc5d64df2c7fcc5179737cdddd6b2 (patch)
tree8ca2171da924c6e1d8a3b2cfed52b71477f64452 /dev-python/bandit
parentdev-python/cftime: add 1.6.0 (diff)
downloadgentoo-6922e71e8dcdc5d64df2c7fcc5179737cdddd6b2.tar.gz
gentoo-6922e71e8dcdc5d64df2c7fcc5179737cdddd6b2.tar.bz2
gentoo-6922e71e8dcdc5d64df2c7fcc5179737cdddd6b2.zip
dev-python/bandit: add 1.7.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest1
-rw-r--r--dev-python/bandit/bandit-1.7.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index 5d7fd5714ebd..39d9c1e94443 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1,2 +1,3 @@
DIST bandit-1.7.2.tar.gz 497104 BLAKE2B 235e8c29658db9b0916b2108a46931581384851650217a7e368f06fe9225aadf181b320a75061387b277d1e3ff3f1d38fe6d07be14f7c7d056fa06e8db84e4e4 SHA512 fde27d409dcb867285f3c7a9ee88a079dae58211e17c2157601bbff9e9144e604def3c0179a7c9016266bdf70ed9da9ca519641f4aca4e76a30859c8e01177b9
DIST bandit-1.7.3.tar.gz 495009 BLAKE2B fb31ae7a5115ec98ba9b62100a2601552e6ca54b9f57fe61e0bb3f2b4b107cc83c25425a43e2681a1e83d7606e209089cbfa95068bb3dc0f35f188b75a307390 SHA512 4a95c67185446ba4250bb2e37dcafb423d4985952122793a698788f8d973ac700964dce0603b5d547d4b74f82272593bc72be266c34ec73af903f3d016015148
+DIST bandit-1.7.4.tar.gz 495104 BLAKE2B 5531a602dea877745ebdecf768fa83e0e478c52d472fbfdf98fec32c73a76a73e4f6dd957be760b4757e47c5f9cc25f6cd2f6c593df1e54165e647950a9f8a54 SHA512 93e1a25fd41e9409971f4cbac2ff73971ba270936a6b2aeecb3e0a2aa2015bcefd5eaab3cc94b2d9d96e4604d1a39c5ca1150c9eadd073357a90c5265c592407
diff --git a/dev-python/bandit/bandit-1.7.4.ebuild b/dev-python/bandit/bandit-1.7.4.ebuild
new file mode 100644
index 000000000000..bee6bbb3bc1a
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://github.com/PyCQA/bandit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~s390 ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest