summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 07:24:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-26 08:32:55 +0100
commita351704ec04d085b1d597ac8b349a2b5f1e7fe6f (patch)
treef3401216bcc9fc3f9a208754a71afd2c1830e5b8 /dev-python/bandit
parentdev-python/numpy: Stabilize 1.21.5 sparc, #831536 (diff)
downloadgentoo-a351704ec04d085b1d597ac8b349a2b5f1e7fe6f.tar.gz
gentoo-a351704ec04d085b1d597ac8b349a2b5f1e7fe6f.tar.bz2
gentoo-a351704ec04d085b1d597ac8b349a2b5f1e7fe6f.zip
dev-python/bandit: Bump to 1.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest1
-rw-r--r--dev-python/bandit/bandit-1.7.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index 4c4d06db5849..a13401c8ce4c 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1 +1,2 @@
DIST bandit-1.7.1.tar.gz 503072 BLAKE2B 1e88b662d8dda0d5c1a1fd7ee2eaa1787b8c4952acefb60c347aa98b3534d9ba212229b050dcf717169fb39132ef77d2d92af834392a0bcaa0b9fbc7d2a4804c SHA512 6543bb0f69339a8d970cf0dd1bcec1392057c5c7fbf229fa4f4e6c9d21a39206f1f3fa17509ca2038cd1671d4b57316f92ee053c1beab102e8d20096d10b685d
+DIST bandit-1.7.2.tar.gz 497104 BLAKE2B 235e8c29658db9b0916b2108a46931581384851650217a7e368f06fe9225aadf181b320a75061387b277d1e3ff3f1d38fe6d07be14f7c7d056fa06e8db84e4e4 SHA512 fde27d409dcb867285f3c7a9ee88a079dae58211e17c2157601bbff9e9144e604def3c0179a7c9016266bdf70ed9da9ca519641f4aca4e76a30859c8e01177b9
diff --git a/dev-python/bandit/bandit-1.7.2.ebuild b/dev-python/bandit/bandit-1.7.2.ebuild
new file mode 100644
index 000000000000..073ca031a6d0
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://github.com/PyCQA/bandit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~s390 ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install unittest