summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-15 20:38:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-15 21:04:07 -0500
commitc419624977fbd0b5972667fcb56f4aeedb8c9c97 (patch)
treebdf0c69f19e568b3743e2e8a30a7743392c53f1f /dev-python/bandit
parentdev-python/hacking: add py38 (diff)
downloadgentoo-c419624977fbd0b5972667fcb56f4aeedb8c9c97.tar.gz
gentoo-c419624977fbd0b5972667fcb56f4aeedb8c9c97.tar.bz2
gentoo-c419624977fbd0b5972667fcb56f4aeedb8c9c97.zip
dev-python/bandit: set DISTUTILS_USE_SETUPTOOLS=rdepend
Closes: https://bugs.gentoo.org/748015 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/bandit-1.6.2.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/bandit/bandit-1.6.2.ebuild b/dev-python/bandit/bandit-1.6.2.ebuild
index f4cbf20f2c3f..e3b22ec991b3 100644
--- a/dev-python/bandit/bandit-1.6.2.ebuild
+++ b/dev-python/bandit/bandit-1.6.2.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -17,10 +17,8 @@ KEYWORDS="~amd64 ~arm64 ~s390 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
test? (
>=dev-python/coverage-4.0[${PYTHON_USEDEP}]
!~dev-python/coverage-4.4[${PYTHON_USEDEP}]
@@ -35,7 +33,7 @@ DEPEND="
>=dev-python/pylint-1.4.5[${PYTHON_USEDEP}]
)"
RDEPEND="
- ${CDEPEND}
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
>=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.13.0[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]