summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-28 08:24:48 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-28 09:28:28 +0100
commitd27338a64d4ae6493315378f198bca218955cd0b (patch)
tree2e596ce45012c0d4be76595f474922385f293987 /dev-python/bandit
parentdev-python/imageio: Bump to 2.16.1 (diff)
downloadgentoo-d27338a64d4ae6493315378f198bca218955cd0b.tar.gz
gentoo-d27338a64d4ae6493315378f198bca218955cd0b.tar.bz2
gentoo-d27338a64d4ae6493315378f198bca218955cd0b.zip
dev-python/bandit: Bump to 1.7.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest1
-rw-r--r--dev-python/bandit/bandit-1.7.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index bc68efb21fb0..5d7fd5714ebd 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1 +1,2 @@
DIST bandit-1.7.2.tar.gz 497104 BLAKE2B 235e8c29658db9b0916b2108a46931581384851650217a7e368f06fe9225aadf181b320a75061387b277d1e3ff3f1d38fe6d07be14f7c7d056fa06e8db84e4e4 SHA512 fde27d409dcb867285f3c7a9ee88a079dae58211e17c2157601bbff9e9144e604def3c0179a7c9016266bdf70ed9da9ca519641f4aca4e76a30859c8e01177b9
+DIST bandit-1.7.3.tar.gz 495009 BLAKE2B fb31ae7a5115ec98ba9b62100a2601552e6ca54b9f57fe61e0bb3f2b4b107cc83c25425a43e2681a1e83d7606e209089cbfa95068bb3dc0f35f188b75a307390 SHA512 4a95c67185446ba4250bb2e37dcafb423d4985952122793a698788f8d973ac700964dce0603b5d547d4b74f82272593bc72be266c34ec73af903f3d016015148
diff --git a/dev-python/bandit/bandit-1.7.3.ebuild b/dev-python/bandit/bandit-1.7.3.ebuild
new file mode 100644
index 000000000000..bee6bbb3bc1a
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://github.com/PyCQA/bandit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~s390 ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest