summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 14:37:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 00:01:22 +0100
commitd4ec59abecfd8c45e798917b01876bb6eb72a245 (patch)
treefa15517e24e91a6cc90cab3faa49a3c744d769e5 /dev-python/bandit
parentdistutils-r1.eclass: Improve PEP 517 einfo output (diff)
downloadgentoo-d4ec59abecfd8c45e798917b01876bb6eb72a245.tar.gz
gentoo-d4ec59abecfd8c45e798917b01876bb6eb72a245.tar.bz2
gentoo-d4ec59abecfd8c45e798917b01876bb6eb72a245.zip
dev-python/bandit: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/bandit-1.7.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/bandit/bandit-1.7.2-r1.ebuild b/dev-python/bandit/bandit-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..0857a573ec73
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://github.com/PyCQA/bandit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~s390 ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest