summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-24 10:51:55 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-24 10:51:55 -0600
commite821261fcef40fe30b83943abc7eca8bf3f7c8f7 (patch)
tree4211aafdde891fc9547a323524266e07d708f3fc /dev-python/bandit
parentmedia-sound/pulseeffects: cleanup (diff)
downloadgentoo-e821261fcef40fe30b83943abc7eca8bf3f7c8f7.tar.gz
gentoo-e821261fcef40fe30b83943abc7eca8bf3f7c8f7.tar.bz2
gentoo-e821261fcef40fe30b83943abc7eca8bf3f7c8f7.zip
dev-python/bandit: 1.6.2 bump
Closes: https://bugs.gentoo.org/710506 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest1
-rw-r--r--dev-python/bandit/bandit-1.6.2.ebuild47
-rw-r--r--dev-python/bandit/metadata.xml2
3 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index 87999002a9f1..f124e1c0046c 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1 +1,2 @@
DIST bandit-1.5.1.tar.gz 480856 BLAKE2B f8a1a7dc1d93a1b6c8d3eb5bcbecda895b29dfebe055ac358b9437bd0c9ab5562e6d25a658bc2092cff6bddfd0245e71bf39ee88b2718e3a0c7376fa50293ae1 SHA512 e6f596e73af45ca2ff4d200fad63d37adf44efd5de52f8061f5a349b66457a39eb442ad442d5fb57b2e0e98c8bae0eb0879b958ff619b4e26c0183bc8b928e36
+DIST bandit-1.6.2.tar.gz 498567 BLAKE2B ab7885df634ff8258fc7620523b56995cb2f262f4290193a9063e216f66ba8ecb31ec17f09d0b72a0472923266953c46e47e74fcdfb39784873738c033e00c6c SHA512 9facce98411ceb9e33e5a978ca4aad2dab541ffe215e480806ac921b7f7067572445d8e32e8d473ef30bb57155b72b2ffd4e06d458a3da82e2a9fb1b1d8a4b9f
diff --git a/dev-python/bandit/bandit-1.6.2.ebuild b/dev-python/bandit/bandit-1.6.2.ebuild
new file mode 100644
index 000000000000..3f077f18a76b
--- /dev/null
+++ b/dev-python/bandit/bandit-1.6.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://github.com/PyCQA/bandit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~s390 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hacking-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-1.0.0
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.4.5[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/git-python-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ stestr init
+ stestr run || die
+}
diff --git a/dev-python/bandit/metadata.xml b/dev-python/bandit/metadata.xml
index 8ee1f52b6c10..40f27867ff32 100644
--- a/dev-python/bandit/metadata.xml
+++ b/dev-python/bandit/metadata.xml
@@ -6,7 +6,7 @@
<name>Matthew Thode</name>
</maintainer>
<longdescription lang="en">
- A tool designed to find common security issues in Python code.
+ Bandit is a tool designed to find common security issues in Python code. To do this Bandit processes each file, builds an AST from it, and runs appropriate plugins against the AST nodes. Once Bandit has finished scanning all the files it generates a report.
</longdescription>
<upstream>
<remote-id type="pypi">bandit</remote-id>