summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-04-11 11:22:11 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-04-11 11:22:28 -0500
commitd9409129e52a3ef323feb9dae4cd043f49103f07 (patch)
tree46b97962e262c38cce7b41408884a036941e3c6d /dev-python/beagle/beagle-0.2.1.ebuild
parentdev-python/cliff: adding py36 specifier (diff)
downloadgentoo-d9409129e52a3ef323feb9dae4cd043f49103f07.tar.gz
gentoo-d9409129e52a3ef323feb9dae4cd043f49103f07.tar.bz2
gentoo-d9409129e52a3ef323feb9dae4cd043f49103f07.zip
dev-python/beagle: initial add
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'dev-python/beagle/beagle-0.2.1.ebuild')
-rw-r--r--dev-python/beagle/beagle-0.2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/beagle/beagle-0.2.1.ebuild b/dev-python/beagle/beagle-0.2.1.ebuild
new file mode 100644
index 000000000000..b74d95088cb9
--- /dev/null
+++ b/dev-python/beagle/beagle-0.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Beagle is a command line client for Hound, the code search tool."
+HOMEPAGE="http://beagle-hound.readthedocs.io/en/latest/
+ https://github.com/dhellmann/beagle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/cliff-2.11.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.4[${PYTHON_USEDEP}]"