summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-01-20 02:19:38 -0800
committerZac Medico <zmedico@gentoo.org>2017-01-20 02:24:26 -0800
commit501bf6c024ae7537948494fcff444ed351254922 (patch)
treed6056fef8e6475f6598e4b5b7cc5aaee6d377526 /dev-python/billiard
parentdev-lang/ghc: added amd64 and x86 binaries for ghc-8.0.2 (diff)
downloadgentoo-501bf6c024ae7537948494fcff444ed351254922.tar.gz
gentoo-501bf6c024ae7537948494fcff444ed351254922.tar.bz2
gentoo-501bf6c024ae7537948494fcff444ed351254922.zip
dev-python/billiard: version bump to 3.5.0.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/billiard')
-rw-r--r--dev-python/billiard/Manifest1
-rw-r--r--dev-python/billiard/billiard-3.5.0.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/billiard/Manifest b/dev-python/billiard/Manifest
index 9f8a00a9b807..307bb7482f56 100644
--- a/dev-python/billiard/Manifest
+++ b/dev-python/billiard/Manifest
@@ -5,3 +5,4 @@ DIST billiard-3.3.0.21.tar.gz 151141 SHA256 9705f78f0a971b91a70b3b19aa7862401b6e
DIST billiard-3.3.0.22.tar.gz 151192 SHA256 d216181387317f8696c6d1c80a2491258d037493c1f0c6eb58992a549481e77e SHA512 751d6406efa4d4854070921eb91fa000e8cd01adebe36627e6cb1fb2281a9c9ab49694d3692fd666f8782804db5590f1fde9318873bbaa6765bcb45fad517bed WHIRLPOOL 6c25ff76fdfd50dd6cea63504acc412d264f354b2235ef6eab1444e8cf0c737bfd729da1107362bbd3afb1e813fb2c6f709ad9139db8c8a5f3f9f4497573e296
DIST billiard-3.3.0.23.tar.gz 151675 SHA256 692a2a5a55ee39a42bcb7557930e2541da85df9ea81c6e24827f63b80cd39d0b SHA512 2ab83512f5317230066f6f82615bda97c1fe6c0cf98281dc3ed486055584c6899695e6b9905d5825d657111c65c7f3552cf3fc7934ad2e4d4b3da09b538b09ca WHIRLPOOL 704a2b37f5bc176c273dd08509a7330d38ce79d0db98ffc1d18b649fa9b0b4fbcce81ec80fdf43acfeb7cc74e444fd29b1cadaaee88c37e56a234876b610bbfc
DIST billiard-3.5.0.0.tar.gz 155959 SHA256 800fa0ac7b362585d43d2d4b8d6aeb5ada25796121956e15dc1e68cfe5319234 SHA512 c73adb0cd470e66cc6aaca848f24a991df3eda44e7adf0e83d2a7a1e87bba4381b165842e8cd297d43a4d01d4c006953107354b841cdad9fdde4e00e7a80c4f1 WHIRLPOOL 8b63cfd62dcf7f33c6441a6cc0f9fc6b668bef694c823ff6b3ffec3e6ea2d8c183639011d791038c621d83991ae686f9cfae50d8ece87b6c9ff373e935f55740
+DIST billiard-3.5.0.2.tar.gz 157299 SHA256 3eb01a8fe44116aa6d63d2010515ef1526e40caee5f766f75b2d28393332dcaa SHA512 581e1ac361324b36d79e280072952e490ef3470709b094f001c579feda54578c8e7b3e5afc93a5f878a6118c56afff7e59e13b3d3f2ccb2564b9b27cc810dae7 WHIRLPOOL fac0985819710e88d689f2aad628e6ed749f088b980fa09f169f74b962145d4a9cbbe10f5d290fdb0f62ea5b5a2e6d074c30c4a45a3a44db750c2b44e78b8f5a
diff --git a/dev-python/billiard/billiard-3.5.0.2.ebuild b/dev-python/billiard/billiard-3.5.0.2.ebuild
new file mode 100644
index 000000000000..bcd41a35699c
--- /dev/null
+++ b/dev-python/billiard/billiard-3.5.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python multiprocessing fork"
+HOMEPAGE="https://pypi.python.org/pypi/billiard https://github.com/celery/billiard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ )"
+# The usual req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}