summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/billiard
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/billiard')
-rw-r--r--dev-python/billiard/Manifest3
-rw-r--r--dev-python/billiard/billiard-3.3.0.18.ebuild54
-rw-r--r--dev-python/billiard/billiard-3.3.0.19.ebuild55
-rw-r--r--dev-python/billiard/billiard-3.3.0.20.ebuild55
-rw-r--r--dev-python/billiard/metadata.xml9
5 files changed, 176 insertions, 0 deletions
diff --git a/dev-python/billiard/Manifest b/dev-python/billiard/Manifest
new file mode 100644
index 000000000000..e490208675ea
--- /dev/null
+++ b/dev-python/billiard/Manifest
@@ -0,0 +1,3 @@
+DIST billiard-3.3.0.18.tar.gz 150594 SHA256 59c04036f314c11632a49c15c57735ffb9e111983ee8d15e4d3e188be31583c1 SHA512 8d62c1b5d3e979926cb416f6a85597cf2a959559e4f07f76f189e70cf585ef55ddbba9506bc50c2f9a88d8aa00684b7468668748edbd0530a72970334b8e2617 WHIRLPOOL 34ce61559529ca95fb9aed44917541546ce9955212954aa16b783f5ed22e36a3b7700edd46eb4961bf49b1653f9020aaf760ba67b1123b69e78e04af8e9c93fb
+DIST billiard-3.3.0.19.tar.gz 150943 SHA256 6e6b8ec6e45b89389051737c7e6215d8e55a83896eb6212fa726ca76e80c7a19 SHA512 492bbf38a7924394dd89f0528598e37ca1a93fc21bdccded396e036b2457c14a06e44de2c9b80d81e5f55bfd1559a6c5fbf1969d108089dc2b697aeaecea60ad WHIRLPOOL cb6e96a1b0c19c62ea07854e7520acb04fa716f79f499e00c24b46f0403ac80d1416fe9669d7e9e1c4955341b29d9215b2e9429d482a4ab34c710397c0fc5e2d
+DIST billiard-3.3.0.20.tar.gz 150990 SHA256 688f9466b1c3ae14106381e6dbd328115e75c5260c542eb48e6c46931f6928cc SHA512 e068be5e0bc8bc68a38dd1cec2574da25494cfac2d9b4b951af3fd9f019080a4fe402d4b407162bcc0edbd0ac4fa406a964913e4bf1dd98dbf8a937294a34321 WHIRLPOOL 41a2ae0648d7f960c569491d0dea519787e3ba779fa27e71c2dcf12e7955175cf3b9697ca750f4e164e263abd880af287f5645c0864115ef88bb0088d31b74c2
diff --git a/dev-python/billiard/billiard-3.3.0.18.ebuild b/dev-python/billiard/billiard-3.3.0.18.ebuild
new file mode 100644
index 000000000000..ca047c18b01b
--- /dev/null
+++ b/dev-python/billiard/billiard-3.3.0.18.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python multiprocessing fork"
+HOMEPAGE="http://pypi.python.org/pypi/billiard https://github.com/celery/billiard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/unittest2-0.4.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# The usual req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ # The teardown in __init__.py breaks pypy's installed nose
+ if [[ "${EPYTHON}" == pypy ]]; then
+ rm lib/billiard/tests/__init__.py || die
+ echo "from __future__ import absolute_import" >> ./lib/billiard/tests/__init__.py || die
+ fi
+ nosetests billiard.tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/billiard/billiard-3.3.0.19.ebuild b/dev-python/billiard/billiard-3.3.0.19.ebuild
new file mode 100644
index 000000000000..bc522833d1e5
--- /dev/null
+++ b/dev-python/billiard/billiard-3.3.0.19.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python multiprocessing fork"
+HOMEPAGE="http://pypi.python.org/pypi/billiard https://github.com/celery/billiard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/unittest2-0.4.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy pypy3 )
+ )"
+# The usual req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ # The teardown in __init__.py breaks pypy's installed nose
+ if [[ "${EPYTHON}" == pypy ]]; then
+ rm lib/billiard/tests/__init__.py || die
+ echo "from __future__ import absolute_import" >> ./lib/billiard/tests/__init__.py || die
+ fi
+ nosetests billiard.tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/billiard/billiard-3.3.0.20.ebuild b/dev-python/billiard/billiard-3.3.0.20.ebuild
new file mode 100644
index 000000000000..6654e760aa3b
--- /dev/null
+++ b/dev-python/billiard/billiard-3.3.0.20.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python multiprocessing fork"
+HOMEPAGE="http://pypi.python.org/pypi/billiard https://github.com/celery/billiard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/unittest2-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.4[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy pypy3 )
+ )"
+# The usual req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ # The teardown in __init__.py breaks pypy's installed nose
+ if [[ "${EPYTHON}" == pypy ]]; then
+ rm lib/billiard/tests/__init__.py || die
+ echo "from __future__ import absolute_import" >> ./lib/billiard/tests/__init__.py || die
+ fi
+ nosetests billiard.tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/billiard/metadata.xml b/dev-python/billiard/metadata.xml
new file mode 100644
index 000000000000..f0333ed8cdaf
--- /dev/null
+++ b/dev-python/billiard/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">billiard</remote-id>
+ <remote-id type="github">celery/billiard</remote-id>
+ </upstream>
+</pkgmetadata>