summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/bitarray
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/bitarray')
-rw-r--r--dev-python/bitarray/Manifest1
-rw-r--r--dev-python/bitarray/bitarray-0.8.1.ebuild20
-rw-r--r--dev-python/bitarray/metadata.xml21
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/bitarray/Manifest b/dev-python/bitarray/Manifest
new file mode 100644
index 000000000000..8f2e33d78665
--- /dev/null
+++ b/dev-python/bitarray/Manifest
@@ -0,0 +1 @@
+DIST bitarray-0.8.1.tar.gz 46877 SHA256 7da501356e48a83c61f479393681c1bc4b94e5a34ace7e08cb29e7dd9290ab18 SHA512 10f4872243b92cd5a1a77e1e2aca80135d31904e17cb3de4eb2c3f2c4d3f00ad0573b6bc4b9c9379594e2912cb0e5d5870fb4e59eb298e269ecb3778fbae7d1f WHIRLPOOL 93baffe0494872933e4726e9e8c37c3ae7969d621356e2a1b68b7056992d7bcb1e5362c9ae78265884c25398faddaaa7447a3e7c40b82a0528504a728ad8ada3
diff --git a/dev-python/bitarray/bitarray-0.8.1.ebuild b/dev-python/bitarray/bitarray-0.8.1.ebuild
new file mode 100644
index 000000000000..9488774f35b6
--- /dev/null
+++ b/dev-python/bitarray/bitarray-0.8.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_{3,4}})
+
+inherit distutils-r1
+
+DESCRIPTION="efficient arrays of booleans -- C extension"
+HOMEPAGE="https://github.com/ilanschnell/bitarray http://pypi.python.org/pypi/bitarray"
+SRC_URI="mirror://pypi/b/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${PYTHON}" ${PN}/test_${PN}.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/bitarray/metadata.xml b/dev-python/bitarray/metadata.xml
new file mode 100644
index 000000000000..74dd28633c05
--- /dev/null
+++ b/dev-python/bitarray/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>python</herd>
+ <longdescription>
+This module provides an object type which efficiently represents an array of
+booleans. Bitarrays are sequence types and behave very much like usual lists.
+Eight bits are represented by one byte in a contiguous block of memory. The
+user can select between two representations; little-endian and big-endian.
+Most of the functionality is implemented in C. Methods for accessing the
+machine representation are provided. This can be useful when bit level access
+to binary files is required, such as portable bitmap image files (.pbm). Also,
+when dealing with compressed data which uses variable bit length encoding,
+you may find this module useful.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">bitarray</remote-id>
+ <remote-id type="github">ilanschnell/bitarray</remote-id>
+ </upstream>
+</pkgmetadata>