summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-24 11:32:22 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-24 13:10:17 +0100
commit0976072dd7c6b13809251d6a1ff1ef86411be47d (patch)
tree47500dd7a835588e45222296c7a77e5520745f83 /dev-python/blosc/blosc-1.2.3.ebuild
parentdev-python/blosc: Version Bump (diff)
downloadgentoo-0976072dd7c6b13809251d6a1ff1ef86411be47d.tar.gz
gentoo-0976072dd7c6b13809251d6a1ff1ef86411be47d.tar.bz2
gentoo-0976072dd7c6b13809251d6a1ff1ef86411be47d.zip
dev-python/blosc: Drop packages using bundled c-blosc
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/blosc/blosc-1.2.3.ebuild')
-rw-r--r--dev-python/blosc/blosc-1.2.3.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/blosc/blosc-1.2.3.ebuild b/dev-python/blosc/blosc-1.2.3.ebuild
deleted file mode 100644
index db06e86c1a23..000000000000
--- a/dev-python/blosc/blosc-1.2.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="High performance compressor optimized for binary data"
-HOMEPAGE="http://blosc.pydata.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=">=dev-libs/c-blosc-1.3.5"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # remove forced sse2
- sed -i "s|CFLAGS\.append(\"-msse2\")|pass|" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- nosetests -v || die
-}