summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-24 11:30:50 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-24 13:10:17 +0100
commit02c0383ce074a3df81cce03d8a7b3a3e91eca3d1 (patch)
treefd3ffea9a4c6e1a0e047ece5a91cb4a5c23ab865 /dev-python/blosc/blosc-1.2.8.ebuild
parentdev-python/oauth2client: Version Bump (diff)
downloadgentoo-02c0383ce074a3df81cce03d8a7b3a3e91eca3d1.tar.gz
gentoo-02c0383ce074a3df81cce03d8a7b3a3e91eca3d1.tar.bz2
gentoo-02c0383ce074a3df81cce03d8a7b3a3e91eca3d1.zip
dev-python/blosc: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/blosc/blosc-1.2.8.ebuild')
-rw-r--r--dev-python/blosc/blosc-1.2.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/blosc/blosc-1.2.8.ebuild b/dev-python/blosc/blosc-1.2.8.ebuild
new file mode 100644
index 000000000000..2a11ef101793
--- /dev/null
+++ b/dev-python/blosc/blosc-1.2.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="High performance compressor optimized for binary data"
+HOMEPAGE="http://python-blosc.blosc.org https://github.com/Blosc/python-blosc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-libs/c-blosc-1.3.5"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # remove forced sse2
+ sed -i "s|CFLAGS\.append(\"-msse2\")|pass|" setup.py || die
+ export BLOSC_DIR="${EPREFIX}/usr"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ nosetests -v || die
+}