summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-20 09:59:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-20 10:27:48 +0100
commite540d37f8720feffc7b4382ed16b5f54c65fb887 (patch)
treea1e4a08d690653d9eaf8e97d23a0d19206ecb2df /dev-python/blosc
parentdev-python/tox: Bump to 3.21.2 (diff)
downloadgentoo-e540d37f8720feffc7b4382ed16b5f54c65fb887.tar.gz
gentoo-e540d37f8720feffc7b4382ed16b5f54c65fb887.tar.bz2
gentoo-e540d37f8720feffc7b4382ed16b5f54c65fb887.zip
dev-python/blosc: Bump to 1.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/blosc')
-rw-r--r--dev-python/blosc/Manifest1
-rw-r--r--dev-python/blosc/blosc-1.10.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/blosc/Manifest b/dev-python/blosc/Manifest
index 9cbd9400b124..527dee909a82 100644
--- a/dev-python/blosc/Manifest
+++ b/dev-python/blosc/Manifest
@@ -1,3 +1,4 @@
DIST blosc-1.10.0.tar.gz 845312 BLAKE2B 15f367f1420f56e64ec01e74d7320adc194db11d15bd26a2b78c59c88a6127f1d2b5fc7bd53e02a6d0cad785c87cf79bb909dec62982b5ee8620c92ccdd80249 SHA512 f071d131966acd74cf71f8688ae9830091ee12a92399e8736f2b2cc2243bc022f9fd194c60493e912aef87a54202813a67a8f9bddd90c1c44631205d58c3f3e3
DIST blosc-1.10.1.tar.gz 858162 BLAKE2B 768ae6d438d9fe05589460dcaeea77dbf2e0212bbc67388c6df1b9fc6bd1921e8cd79da2039cd4300cd91923d7988f8c4741ea1dbd5ebfa13e48f3ade678ac09 SHA512 06e393efa3fc7060205a483787eb4c5befe75dfdd6321b37c43ed7830dccf4d622bd88451e97da663ed9dc9302c30d7486315de9aff6351721862e2eceddd9a3
+DIST blosc-1.10.2.tar.gz 858096 BLAKE2B ff314011e1afc2d972c2445df9ad25c245494479201ddd0944ddf5f14aa0aa772c9da1e117eb5395f5488e7238aefe1236d9a5579b4d03be2b041790de9575e8 SHA512 82dab50a49ddd45d8276fd43999233f41b507e35af5897ed4945565fde8f56be0855b0dd926d254bd77904ec7a13ad3f024007159510b677769d97599b731222
DIST blosc-1.9.2.tar.gz 816897 BLAKE2B 7d1a2d925500c8ddb93975dd785c03b91dec2716a438915d5dfdb739c650de8a47ed80eb25fc55357e69b586c446c5af61212e0a4fba8158839a66849309f478 SHA512 a8f53afb7fb1bb742e2daa03015b636d4dbb1fd073be079022364ec67035c9e6ee372ab07f7ce06579b85d9fcaedd2a11f30b9cf5b2bd1d1ea62cf32a8aa3c1f
diff --git a/dev-python/blosc/blosc-1.10.2.ebuild b/dev-python/blosc/blosc-1.10.2.ebuild
new file mode 100644
index 000000000000..43923c61a128
--- /dev/null
+++ b/dev-python/blosc/blosc-1.10.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="High performance compressor optimized for binary data"
+HOMEPAGE="http://python-blosc.blosc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-libs/c-blosc-1.19.0:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/scikit-build[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( ANNOUNCE.rst README.rst RELEASE_NOTES.rst )
+PATCHES=(
+ "${FILESDIR}"/blosc-1.10.0-unbundle.patch
+)
+
+python_prepare_all() {
+ export BLOSC_DIR="${EPREFIX}/usr"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" -m blosc.test -v || die
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}