summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-14 13:14:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-14 13:29:25 +0100
commit99e8a93d029cb2370fb08397cdb6cd7b459b2353 (patch)
tree81a4fb98ee167ec0cf0dff361295f722a410e007 /dev-python/boto/boto-2.49.0-r4.ebuild
parentdev-python/pyzotero: Tested on py3.10 (diff)
downloadgentoo-99e8a93d029cb2370fb08397cdb6cd7b459b2353.tar.gz
gentoo-99e8a93d029cb2370fb08397cdb6cd7b459b2353.tar.bz2
gentoo-99e8a93d029cb2370fb08397cdb6cd7b459b2353.zip
dev-python/boto: Add py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto/boto-2.49.0-r4.ebuild')
-rw-r--r--dev-python/boto/boto-2.49.0-r4.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/boto/boto-2.49.0-r4.ebuild b/dev-python/boto/boto-2.49.0-r4.ebuild
index 113359bc0b19..5e32f2f4e2b1 100644
--- a/dev-python/boto/boto-2.49.0-r4.ebuild
+++ b/dev-python/boto/boto-2.49.0-r4.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}"/${P}-py3-httplib-strict.patch
"${FILESDIR}"/${P}-py3-server-port.patch
"${FILESDIR}"/${P}-unbundle-six.patch
+ "${FILESDIR}"/${P}-py310.patch
)
RDEPEND=">=dev-python/six-1.12.0[${PYTHON_USEDEP}]"