summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-09-13 11:59:54 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-09-13 12:08:05 -0500
commita5c91e1728e5ccdd17dac20f09329e7d3bfbdbe8 (patch)
treea2758c9de2b925dce269d9b9d0a225d7cf8174ff /dev-python/boto3/boto3-1.1.3.ebuild
parentpackage.mask: Clean up old entries. (diff)
downloadgentoo-a5c91e1728e5ccdd17dac20f09329e7d3bfbdbe8.tar.gz
gentoo-a5c91e1728e5ccdd17dac20f09329e7d3bfbdbe8.tar.bz2
gentoo-a5c91e1728e5ccdd17dac20f09329e7d3bfbdbe8.zip
dev-python/boto3: add version 1.1.3
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/boto3/boto3-1.1.3.ebuild')
-rw-r--r--dev-python/boto3/boto3-1.1.3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/boto3-1.1.3.ebuild b/dev-python/boto3/boto3-1.1.3.ebuild
new file mode 100644
index 000000000000..f67bcade54ca
--- /dev/null
+++ b/dev-python/boto3/boto3-1.1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/botocore-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/botocore-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.6.2[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '=dev-python/futures-2.2.0[${PYTHON_USEDEP}]' 'python2_7')
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}