summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-19 03:38:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-19 03:38:01 +0200
commit19e5bd8598d98de397e339489751e8581550dfaf (patch)
treef7fd13342b8c8360192c060f0168f5bb8571bab8 /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.87 (diff)
downloadgentoo-19e5bd8598d98de397e339489751e8581550dfaf.tar.gz
gentoo-19e5bd8598d98de397e339489751e8581550dfaf.tar.bz2
gentoo-19e5bd8598d98de397e339489751e8581550dfaf.zip
dev-python/boto3: Bump to 1.34.87
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.87.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1563a62fa4a1..a3ed73021adc 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.34.79.gh.tar.gz 792796 BLAKE2B 97a4f8e6fc33bcfe2817ce353df8ff6354bc
DIST boto3-1.34.84.gh.tar.gz 796658 BLAKE2B 76ad7997f92167f1ed2f14a0a780a1a58b4a853ea132ca38797a228382ad8f55264dfaee99ebf6f8e2bea1848ec918f7b3b0943d0bb6a81b3b858e729b2e74c4 SHA512 55988d7ba69a46b986ed2cffd46b37a154baaa3a73ce62d9ee5b4b8b6f8987f714034ae4f3e59ed9907920216eaf8b18edea4c0fbac99037979b8b30e3b71133
DIST boto3-1.34.85.gh.tar.gz 797539 BLAKE2B b958d009a7acdd541306f41f8708951ed1bf3d303d5e3b3453307415ddc8cf6f6d3c7ed464f350d1a36646729095b1684a865f5982d2ae9b3d7facf596c8b579 SHA512 91295f89896a705c3cbb941fa55e8d227b12dc28290ca15a31ebf60e936ea805233d7b14c6097c9757f6c7ff310159bcc1f2a2e46227d98b6d04adf9c6d44a33
DIST boto3-1.34.86.gh.tar.gz 797728 BLAKE2B e0ff81aab27782e69e69dedf1ef227d6539f4253df6e9e7f0daa9d3d033a646c359df2a9aa49192350f43ba852384220379e794a3c89f368224bee28b292d371 SHA512 7303cbf0a49d2ec085e5a0798f658c799e1ffd02cf3387ab13ccc403c152009184ee71f73b07bcd6a166b686c530aadd8cd77644eb0c72b517910d2a332959fc
+DIST boto3-1.34.87.gh.tar.gz 798511 BLAKE2B d4bb92b25fcd6d2824ff27b89d66731d67e5a34034047501ecde18c6236821542b04d46b3bd6b9d2dcfe14939c114bf26208a8650e96336eb4aba3424154a4d5 SHA512 54c47eb5c1f118ca0a3db79fc3959e96658fabc2d2c98e728dfb8b6bb6f062bf765ac10bae22c12a2474ad36d75cef95774ffcb0fbcc4054f4d07b683235ec87
diff --git a/dev-python/boto3/boto3-1.34.87.ebuild b/dev-python/boto3/boto3-1.34.87.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.87.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}