summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-14 07:47:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-14 09:50:54 +0200
commit1b9fb6b53b97f90d5d23e34f247353ce325a6a8b (patch)
treebfbe3844b554c3242b6c8dfb51286dd9e2e7d3b7 /dev-python/boto3
parentdev-python/botocore: Bump to 1.21.61 (diff)
downloadgentoo-1b9fb6b53b97f90d5d23e34f247353ce325a6a8b.tar.gz
gentoo-1b9fb6b53b97f90d5d23e34f247353ce325a6a8b.tar.bz2
gentoo-1b9fb6b53b97f90d5d23e34f247353ce325a6a8b.zip
dev-python/boto3: Bump to 1.18.61
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.61.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 4bb337188242..54ddd92f5811 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.18.40.tar.gz 412065 BLAKE2B c548c6a1f5cfac3d304384b56882943201c45f3
DIST boto3-1.18.47.tar.gz 420701 BLAKE2B e58f528d876a29cd992a414e84a807a4fefdeb14b37e0c520f677d61270acd2bd534bd49ccb571d21f41a210946a1897f324a1c41a7e5fd9fe86a8689bc835da SHA512 67075c3d25a99bb3bda44f5108004a672b7f52f00f945f7643063d8c435854d14ffdc98d88d48e80caef850e4d765a7a9a894410398c56518a5cd30e32a7e481
DIST boto3-1.18.53.tar.gz 422176 BLAKE2B a07155f6be71c049479c1d2e47767bb2c6863075ea0085ca5cc4609e28aa8b0af0e2136754c0ed6fd05dfecab079f76d636e19e1b8af4b68220768cea6125e93 SHA512 ae774e3db52a90a0850b4bd90be105d4ab59b6478ed16e30e2cc5afec0664e2b13438ab7a460e570c680d49be240855b7c9ae30a373c83d50dda5da6b84d01b7
DIST boto3-1.18.60.tar.gz 428327 BLAKE2B d559c7512c7ab1160dfec4616741002ce82357d3469747044bf79f90baba5e6e3d2f2ecf32ae4cad7522a341d846d199cf34555376d05d56cdbfccc75d0f9042 SHA512 e013ec97b4379cbd3f21f000974d8078a2710f29a9a7d34532fa06c9011fb566238d38d45abd5ecad5b26ad544f72b86ae191fe475bd0d729d290553cd461ff8
+DIST boto3-1.18.61.tar.gz 428681 BLAKE2B 54aa44e4c1756172b5feada7c32a52d32a7938f284ff4ecad9964f74a340ee0cea5bbf1cae189ce90e3a38902398c10af739ec41da895104b10198e63e0d5cb1 SHA512 361e326d003879e81a9de00d469f5b6910c44ec4a4a2109db96b30f46499cdd07e80bd2ba4aeb7be149d9c5a0ead08c1d574369ddc90e31fb564eaab944c6cde
diff --git a/dev-python/boto3/boto3-1.18.61.ebuild b/dev-python/boto3/boto3-1.18.61.ebuild
new file mode 100644
index 000000000000..450c87d9f8b7
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.61.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}