summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-29 12:10:54 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-29 12:12:00 -0700
commit1e1502b5e484e6a085943e583bcc314efe55a9eb (patch)
tree26b71108f34f12d8ee1fd82bdc64824b8921f698 /dev-python/boto3
parentdev-python/boto3-1.12.48: version bump, add py38 (diff)
downloadgentoo-1e1502b5e484e6a085943e583bcc314efe55a9eb.tar.gz
gentoo-1e1502b5e484e6a085943e583bcc314efe55a9eb.tar.bz2
gentoo-1e1502b5e484e6a085943e583bcc314efe55a9eb.zip
dev-python/boto3-9999: sync with 1.12.48
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/boto3-9999.ebuild51
1 files changed, 26 insertions, 25 deletions
diff --git a/dev-python/boto3/boto3-9999.ebuild b/dev-python/boto3/boto3-9999.ebuild
index b19ce9f817ab..d996a7288df9 100644
--- a/dev-python/boto3/boto3-9999.ebuild
+++ b/dev-python/boto3/boto3-9999.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit distutils-r1 vcs-snapshot
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
DESCRIPTION="The AWS SDK for Python"
HOMEPAGE="https://github.com/boto/boto3"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
+IUSE="test"
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/boto/boto3"
@@ -22,33 +21,35 @@ else
fi
RDEPEND="
- >=dev-python/botocore-1.12.4[${PYTHON_USEDEP}]
- dev-python/jmespath[${PYTHON_USEDEP}]
- dev-python/s3transfer[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.15.48[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
+BDEPEND="
+ test? ( ${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
)
"
-python_compile_all() {
- use doc && emake -C docs html
+RESTRICT="!test? ( test )"
+
+distutils_enable_sphinx docs \
+ 'dev-python/guzzle_sphinx_theme'
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
}
python_test() {
nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
-
- distutils-r1_python_install_all
-}