summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-04 05:13:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-04 05:58:00 +0200
commit2a6ec930958da533693f0c5ceaefa02a8f140ce7 (patch)
tree0aaaf6dcee8ec777c209a89bc397634dca282afc /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.77 (diff)
downloadgentoo-2a6ec930958da533693f0c5ceaefa02a8f140ce7.tar.gz
gentoo-2a6ec930958da533693f0c5ceaefa02a8f140ce7.tar.bz2
gentoo-2a6ec930958da533693f0c5ceaefa02a8f140ce7.zip
dev-python/boto3: Bump to 1.34.77
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.77.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 318ffd2ebe77..6336a64a224d 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.34.69.gh.tar.gz 787293 BLAKE2B 9e46a959f3efdc3e673d38c8e3c30b8ceed1
DIST boto3-1.34.74.gh.tar.gz 790202 BLAKE2B 4368db3e11d6bda6eee4ccde82bcc0c2c5a67448400ce0d29d221840360348ab1c7d3c8360ff3c91190ebccb30e187c6fc3ed72f29f1a1d1f883888a8cad12dc SHA512 977e1b9f8a9506bd040ff6a9a1df106294ff62a100cf5cb31aeaa363a4f3fe28cab71e4740028202829fac3023bf832bd4ac25b3474c2a5e107892c05b356e0c
DIST boto3-1.34.75.gh.tar.gz 790632 BLAKE2B 846170851c821e72b05b2c94470bc48ed542722ccec5360f03d6f5d6393a4163b21b40ac68f586748106991e501cfc5c66c5dc15e9931605a062c2cd1ef1f46d SHA512 581c5a823297066deeaf832b46d1f14db54df279ccd25c9ae2ba4896389a37f453a732e5291bbd2bec1bfa2107ce1f0efcbaee7b765ba101bec31fac40ca37dc
DIST boto3-1.34.76.gh.tar.gz 790998 BLAKE2B fb4db194a2b8257400c0d15b266b1017d93eebf1171d9be26917e2aca7b5bb9f4c7986b035c99c4fdfc1b9eecbf0b4a26dfaaac4871712c6da72ff803e4f60c8 SHA512 bbd0868db23812ee706b8adf9221606b07a5da288c673fee2287c44c23c1023782fd00bd341486900f4ef2e87c1b6392cc59996b22588947ccd6f50c58d3b5cd
+DIST boto3-1.34.77.gh.tar.gz 791765 BLAKE2B 2c4c9f81e027403c6fe910d369644ad682bfc8edc4a6c8385eac98db3df3e17029d24e0b7f162537d88eb4b49680eee79ab3e3fcbbd413d8e8100f455960cfab SHA512 c3beec62805e943e50035d1754e582d361dde8bc6a165c7203cbeeab2aa1f4e0d67788fa7f53d10d875db1c4332e07a43b1224b9a46dfa825bb02187d5134e36
diff --git a/dev-python/boto3/boto3-1.34.77.ebuild b/dev-python/boto3/boto3-1.34.77.ebuild
new file mode 100644
index 000000000000..b64e7191fd19
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.77.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}