summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-04 05:20:14 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-04 05:59:59 +0200
commit36cf36e13ae56f8c9b3ac5a3587b9854d93a865f (patch)
tree92e9756e1565dcca10fec9b8dbe8b9532e446c6e /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.98 (diff)
downloadgentoo-36cf36e13ae56f8c9b3ac5a3587b9854d93a865f.tar.gz
gentoo-36cf36e13ae56f8c9b3ac5a3587b9854d93a865f.tar.bz2
gentoo-36cf36e13ae56f8c9b3ac5a3587b9854d93a865f.zip
dev-python/boto3: Bump to 1.34.98
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.98.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 5d7e2c6d377e..7e3f4c08e189 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.34.94.gh.tar.gz 803022 BLAKE2B fcc522fc68e31fae8086e21740e7ac286f4d
DIST boto3-1.34.95.gh.tar.gz 804506 BLAKE2B 81bc8a68138e391dca19894fb42eb9c55b155463bf7baa4dbd5ab876d94e6a4174eefe23938990e64bc0e6391e46ab764436c2ef0debb544f204ac1e5321212a SHA512 efc8df42dc0b65061e564ed60996a750e43feb44ef9c71f58dec04e3c2644172f2fc19f01ed877f8c1a29da2ba367bbfb2d77085e5443e9b84ef003de2bf6e50
DIST boto3-1.34.96.gh.tar.gz 804809 BLAKE2B 7dfdf70f817d4f0c69f67b96f329ce4cf939f2c5cb87208faecbb160c304ef9bc0342929a336b159331dfb80a68b49e4d07d3324a7df3e60ea33a440483bc9c8 SHA512 4ef57ced14d6a882e2b3358cbedc632a00f1d55a70d831ba597e7ff785e44ab0e37882373d07e0385be830f5c940f7cba6b0f0b6ddeea65640c07d0083ea98e7
DIST boto3-1.34.97.gh.tar.gz 805053 BLAKE2B d5759279a231be0e65ae4c4a6c574cf0af0ef96509c150b8fa28f89ed19f111979f71f4297fe8695576fd0dcf1f43b65ca2f51fd41f9c5c51135c8d33b4175a4 SHA512 38e9bf181597ee4963189cc7b1a332f47bdb72ebc670a85be7e737aa60ac7baf1297d2782ece2dfb691dd97ae3cb201d737e5571a6b0ce90271215e983205a17
+DIST boto3-1.34.98.gh.tar.gz 805719 BLAKE2B 5cf7f0cc415e25c8b41aa464b636b1683f4e71198569f5eac3e6e43cef7050e20e92c3fd988517fc1463601073b41b0b9c668a58bb866d03b83973c9b9cd976a SHA512 06cab81bbf73a9c37b68e0312a7c587bace700b8032e283b6782c1275804ea7c93065c4282837957b5cf3523d50fe57319a54af494262e2666f65440da9771fd
diff --git a/dev-python/boto3/boto3-1.34.98.ebuild b/dev-python/boto3/boto3-1.34.98.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.98.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}