summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-07 00:02:15 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-07 00:14:35 +0100
commit4bb371f6b2722428b68cde119f01d61305a4a5e4 (patch)
tree0065d12988406bd807378ba4533c9705aaaa049b /dev-python/boto3
parentdev-python/botocore: Bump to 1.19.13 (diff)
downloadgentoo-4bb371f6b2722428b68cde119f01d61305a4a5e4.tar.gz
gentoo-4bb371f6b2722428b68cde119f01d61305a4a5e4.tar.bz2
gentoo-4bb371f6b2722428b68cde119f01d61305a4a5e4.zip
dev-python/boto3: Bump to 1.16.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.13.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index db48fcafb6ee..9167aea101c6 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,4 +4,5 @@ DIST boto3-1.15.18.tar.gz 336927 BLAKE2B 0ddc7fbd0fffcbeafeee7b9aa0f699087369f31
DIST boto3-1.16.10.tar.gz 338466 BLAKE2B 3b4c1978859679d193fff2d44c9c8f693759527ebf0913e55049332135d6271bf30ad0b935e84867b9b1ceba3c196526dc20c7b2c985c3b16ba8f3a08796d19c SHA512 b582ee69d489f784d6f05f8be634e2f014f55046c11ed1609f624dac006cd3a05bad597ac155c5cc0dce7fb40843de2d2cf48829135c680e91a6d6b2ca15f49e
DIST boto3-1.16.11.tar.gz 338598 BLAKE2B 0cd8f8271e91a459cc4cb669b466ea82f135c37d3f604303defab9d7ae6aaa8809bb64b2f6802a10ba9e5bf687a03ff24739d9c6e549d8539c1af9bc0c9f9e96 SHA512 db6b84d61dc1bb1c62115736e066fbe93f9e3e6f866d6b091b646dd576d4c99ac8dbcdcf80a43b837bc8395c7633d9a633db42fe097f8ba88e68602e44fe88c0
DIST boto3-1.16.12.tar.gz 338648 BLAKE2B ffb266966a51ee1ce91d1062bf5f3500c8176b809e856320ea3feb8994768b6b227db14f00ed749df7afb626e864a933446caa2c714653b8dc6b0b4cac0ccddb SHA512 6f6e114d1be6d7773bdde574f12db1046e56592158960f1a0a67e935df8896afa21e82844b37f27c31af6b9705d6704a8b98b9e8b0aa1a683bce32357582430e
+DIST boto3-1.16.13.tar.gz 338735 BLAKE2B ce2bea512bc01b4a5fabdae7438f88118a61d550604c2aa38b573333dc7bdb1b13d205884084da7f3f0425b994410676920b00c474f81abdce84f2d7c53cf1e8 SHA512 ed7f58fe7529e6ec34f1a3d8d173fce532fe4ee7185657b1dc41186eb42a506d55f2803f69ea0b6ae216a6590f33ad15fff0c31975a6002566b54d7b187d5edc
DIST boto3-1.16.9.tar.gz 337905 BLAKE2B ed01e28fd7e62e5e5028307c93f92004bfbecffa77bc2ba1d6574b92ec2c515d910eb5107ac5ee03e0aca909f97f379aa65b5f839c8067634fa69266c58de33f SHA512 7343b8432788ef981819f91fe2ba27c4ec3947d01ff55914f7c89607250ecf60db2da8d25c8a2c7001ef546a9abed4cb744c5937ca09497aa1a983049648bd5e
diff --git a/dev-python/boto3/boto3-1.16.13.ebuild b/dev-python/boto3/boto3-1.16.13.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.13.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}