summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-24 06:07:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-24 07:16:24 +0200
commit634e031b8d4bc3aacb1d39984637287787899bc1 (patch)
treec4ae873c2fdb51e926ba96c7ba6e1517812a7dad /dev-python/boto3
parentdev-python/botocore: Bump to 1.27.16 (diff)
downloadgentoo-634e031b8d4bc3aacb1d39984637287787899bc1.tar.gz
gentoo-634e031b8d4bc3aacb1d39984637287787899bc1.tar.bz2
gentoo-634e031b8d4bc3aacb1d39984637287787899bc1.zip
dev-python/boto3: Bump to 1.24.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.16.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index e96a1e036006..1623f2103046 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,4 +2,5 @@ DIST boto3-1.24.12.gh.tar.gz 509573 BLAKE2B 5c9978cac1cbce0521dee6f2164652c4fca8
DIST boto3-1.24.13.gh.tar.gz 510032 BLAKE2B 4d204f4b4e1dbe970d45e65eb04061193d1b21236b59f33994d03138e5a1f31fce2d27f7323d1a4da8b5f88d143e1dc51cdc73e19689e79722ae696453d314e3 SHA512 e8962339b1e5c72ace2d9980d7268bd09725b11b30425c32d649703089b32324ca442e597756a14a3d4be222c3628a8ccac4da2d7739cc237dfc29a8ea722818
DIST boto3-1.24.14.gh.tar.gz 510393 BLAKE2B c5a3f28abdeb3deaf33620ab7278b5d14dce55297e37c8d17e58994348f7459598ea96c3d44cfa7cf4bfa760aee2ab09aea0d905d514cc2365b0beb12424ea49 SHA512 d357cfd4e1098a8aa7e59aad36f27427dbc43fe39bfd3628928879058ee396774ebbc2c270fd5422a125f447a7b64fcb34da5008fcf44a8d74ed344b81f65666
DIST boto3-1.24.15.gh.tar.gz 510710 BLAKE2B 9640c037d6bc95225b9dbb9fc8b33d65a4253057b9a534c1dc2f33a5040796b25fe069a1842aee61851b0b5a75c15770564c5348b8937cc38cc8b898a5d01106 SHA512 07b8758afa9454d435a8935e90e7bfbe91ba266fecfd8413f81cb000c86101a8ad14cd9dd7e5ba620dd807da9501409896c36b532d243d68f26b4d0aa8574fbb
+DIST boto3-1.24.16.gh.tar.gz 511182 BLAKE2B 00180c2cee9499efb3093c517f776536a85972014c622ec87d327c0e1a628b1440a85ddb239431d7c647a459f8c55422136f61254cd192cd3ca8f68eb03270d9 SHA512 cc2d179ba3975fdfc1127565d352077529159cd97d120831629650af881600d022f8a55f4ccfb3c732be5814b58739178063042ca7a0e26f0163f47ba8dddb36
DIST boto3-1.24.7.gh.tar.gz 508670 BLAKE2B d526f6a4dc4c6126c61ca7c9074b4341c742f84a6e95b38cd8a450fb74df379cee44513e1be6bc7cd0c8f728598d0ecfc06240120a8da71f75f86371498f5233 SHA512 4d57e38c18138b950f93a234132ac1d31c9a29ad00ca5e1298517d6b16ff2849802ce6cfeb8de390c2eb25086043d45e0276a7a563707595649ca1905367be52
diff --git a/dev-python/boto3/boto3-1.24.16.ebuild b/dev-python/boto3/boto3-1.24.16.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.16.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}