summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-05 09:10:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-05 10:16:52 +0200
commit6411558a0055ec59a132af312a40cc3fea654141 (patch)
tree19f7b8abe480977611cc70f84e44fdd5b4304df5 /dev-python/boto3
parentdev-python/botocore: Bump to 1.25.7 (diff)
downloadgentoo-6411558a0055ec59a132af312a40cc3fea654141.tar.gz
gentoo-6411558a0055ec59a132af312a40cc3fea654141.tar.bz2
gentoo-6411558a0055ec59a132af312a40cc3fea654141.zip
dev-python/boto3: Bump to 1.22.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.22.7.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1eccf950ed89..a642479173ca 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -7,3 +7,4 @@ DIST boto3-1.22.3.tar.gz 495091 BLAKE2B a917cfec2cb77f9c639160be06f610855b625a9c
DIST boto3-1.22.4.tar.gz 495554 BLAKE2B 4c06e2101bcc96e4fab7e088f8593c7b1cfd2b07431d4cd062666df6c1f5d55d9b7fb594268e9a86c4793d35bc3d8de2644244728cf62833dfefb62525eedbdc SHA512 26dbd9ed1af900f7466a1767ada3fb8ee86fa09ca21733f857e2748d98525661fc76e69d75440fe913260e75245cf30298493417d055399a242af0aedaffd349
DIST boto3-1.22.5.tar.gz 495793 BLAKE2B df31095d43413694ecdefbd641b3f5b54d6c45181752c17fa2558930ce1ef92a6245a4b74503ec8ce0c94273ab47eb2c2868893fb95217a864fe6cc9a39f0a6c SHA512 63124dc8d21273dd80d10b18e14c9e0a0fda449c18a4a4b585a4c8a98ab5c0c10a344d3bf3ddc4306c294fc77339a80bd38fbba335ef71350c81564182c581f2
DIST boto3-1.22.6.tar.gz 496139 BLAKE2B 85f35eb258550368ca09244086d3fe91365f0b87c26260d8ef7b77119a70836b582c08c32298df48812a6363835206a2ed88577186efd871e5df3f2eabf4272f SHA512 d21c00aeea4db8f11a8aeddba254ae598246f963eb7d45fcf104d5e5c8fce6aabcc2700e396c6a5e911680a04688800e66b7ecae908d2e186c0a9d591fba04c1
+DIST boto3-1.22.7.tar.gz 496523 BLAKE2B 400370268e51b229bd3c465ccc43df93b713e3088baf76cbb7367cdc75b8374b787fee635cc921b431d5e1471a60a990d57a306d8ebdb14f0c462f211b323f99 SHA512 a7b56723a0fd692496a4e397ca29139f0813bfcea365877900441f01f38e5fd15d20a1642a5717940994bdfc840540d38b9a594e2510ab070ae62fadf9b4958b
diff --git a/dev-python/boto3/boto3-1.22.7.ebuild b/dev-python/boto3/boto3-1.22.7.ebuild
new file mode 100644
index 000000000000..fd6e0d8ebf01
--- /dev/null
+++ b/dev-python/boto3/boto3-1.22.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}