summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-21 09:55:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-21 10:23:57 +0200
commit713c05a9b57f733ae82d33a928be27a6c59679be (patch)
tree21cf470afdf2f469bb1040251bb0e423fe10ceb4 /dev-python/boto3
parentdev-python/botocore: Bump to 1.24.44 (diff)
downloadgentoo-713c05a9b57f733ae82d33a928be27a6c59679be.tar.gz
gentoo-713c05a9b57f733ae82d33a928be27a6c59679be.tar.bz2
gentoo-713c05a9b57f733ae82d33a928be27a6c59679be.zip
dev-python/boto3: Bump to 1.21.44
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.21.44.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1936e4842933..1f1e42525b2c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -9,3 +9,4 @@ DIST boto3-1.21.39.tar.gz 488120 BLAKE2B 7fc998ec59d19fd6ea0377443920e30bcacdce5
DIST boto3-1.21.41.tar.gz 488529 BLAKE2B a07662e4499ea6e833ee7a207dbf84522369ae0609ee7ac305fb8afca572114a938a1c0a23d75404c86c6afc2a516148a565e9ff607898566beb9b552fa44c3e SHA512 620fea69e84de1c6e705a33b00ba137f8550e0590492e13ece24bdf8ba6439be58e31821404a6dded02873a69256568d5061bf9de19ab75c37630865dcf97373
DIST boto3-1.21.42.tar.gz 488786 BLAKE2B eba75a62e2460aeb2ea66641fadb52448314e639af3d3ecb09f2ab48336bfdc78be868a5d710ba295732a65518eaef882a162df4d25cb8cb344aa27ab3f2ecbb SHA512 3ee8a299cad05e4317916286028608f3d289e6c2c3b04606dca8ede9ba7f3e8931321f33c91c40bd9c4aa15a2cab21245de5c26f6637139fa716149fbcac9c2c
DIST boto3-1.21.43.tar.gz 489557 BLAKE2B ad297963b34d176f686f09da408bbd7f236413fa0c1c88231285ab5c742402ad3c4c8e9da463d6de463e4b9e80f8b30f13999bb990435208cc38123fb4720d41 SHA512 b0c800b4d55d0cf6c1af6f2c55ca1e702ff16d2f40a1eda63b5c100e396c8d5fadc99eb6db41e92a8a86f174009758b31f59d7b5e0d3f17dd532f5c3303b374c
+DIST boto3-1.21.44.tar.gz 490125 BLAKE2B 37a18fe2beff3a232f17b809bf19519800b6481f7f2cf727a45ab965d9dee27978ce1efc192fab70925776757c77573eb2703815958dcf8be9388e0fe8081502 SHA512 4ed06c2adf3187d7cbda5ef481883289a83137bd6065c56a61d0b2d452845f55c74ff8bd62f3558463b83abbfccb4c29638d1774c7076539b3e6ec088eefbb6b
diff --git a/dev-python/boto3/boto3-1.21.44.ebuild b/dev-python/boto3/boto3-1.21.44.ebuild
new file mode 100644
index 000000000000..6fcba460ab1d
--- /dev/null
+++ b/dev-python/boto3/boto3-1.21.44.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}