summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-20 08:43:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-20 10:29:11 +0200
commit85da46d2befeba2bdcd991e4c8417d24166234a0 (patch)
tree49ed075acca2c13642e162332a04387ebc441caf /dev-python/boto3
parentdev-python/botocore: Bump to 1.26.4 (diff)
downloadgentoo-85da46d2befeba2bdcd991e4c8417d24166234a0.tar.gz
gentoo-85da46d2befeba2bdcd991e4c8417d24166234a0.tar.bz2
gentoo-85da46d2befeba2bdcd991e4c8417d24166234a0.zip
dev-python/boto3: Bump to 1.23.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.23.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index fcd7a7a2f4cd..06bb2febcd89 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.23.0.tar.gz 499085 BLAKE2B d606370e274564f909be46cfac838212de3213fd
DIST boto3-1.23.1.tar.gz 499867 BLAKE2B 1ea53a7bf5f453a202347f29f0278d5397d6d10cfb52253a64a09ccb6ddfe1a95631045ecf7b526016f314c8773db04d25ed8cd2a539ae20776629079c168b61 SHA512 a1cc49cd53444bbda3fe0bbb1ec6e7e445a53d94af1eda0ed2984f7e0ddc4af14eed09b269cb4b4e62a15d647071bd9a9e5182b7049da745c19ba8da74e5c9b8
DIST boto3-1.23.2.tar.gz 500287 BLAKE2B b997f18cfb2b5c03eab7decd14a60d70546eb60fb2d52f02d94ee478686bd520e4e8111757e9e073f17f7f415d9eb7243fdcd9ac2e0f2b98f6bd6d34473dc794 SHA512 6a774199b719496143af79b1a8a0612441a4f1d9ce426dfc3d495679bb0fda3856b7b0e81e8403d050de52bf8363dec9f0242cca6b32cf39d172d559d6ddf548
DIST boto3-1.23.3.tar.gz 501196 BLAKE2B 8fbe6ec091e249bf675b9245a3ad73416bfae77de8c197f6b5bc6d919e7082aa36b53a93034d5658d7f27c928c932b0f077fc9beea6bbc9015c26e925cc565c2 SHA512 96fa0382a4841901eb961a1135799823710af24c236c4be6def180597bdb53a852fa2c0ea34cf6d1b8cfba0e5c5a2b10f361677a993b733bc14729ee68af16f2
+DIST boto3-1.23.4.tar.gz 501445 BLAKE2B f38c963558c99fade5b55c0b8d96221de7af7a215f7be2a4863285152720318f05cbaf996f8f0910f68830fdbb214b242d2e8e2e538ae345e4877a0ed733c148 SHA512 85298ddbb4a305354c50f4f63e9e6d0a1c821ac18e15dfaaf3d8ea3e03fd86fb6ea913402c6ac5cde4305895f387cf25eca928b7f00403198ad2eb5efe965eb7
diff --git a/dev-python/boto3/boto3-1.23.4.ebuild b/dev-python/boto3/boto3-1.23.4.ebuild
new file mode 100644
index 000000000000..8b87bf9ae488
--- /dev/null
+++ b/dev-python/boto3/boto3-1.23.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}