summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-27 08:13:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-27 09:06:03 +0200
commitbdbef79e8d6c02be09c109de85a8a368f167b177 (patch)
tree9eaa8bf5e5678319b4c666bcd8b2748a77270e3d /dev-python/boto3
parentdev-python/botocore: Bump to 1.26.9 (diff)
downloadgentoo-bdbef79e8d6c02be09c109de85a8a368f167b177.tar.gz
gentoo-bdbef79e8d6c02be09c109de85a8a368f167b177.tar.bz2
gentoo-bdbef79e8d6c02be09c109de85a8a368f167b177.zip
dev-python/boto3: Bump to 1.23.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.23.9.ebuild68
-rw-r--r--dev-python/boto3/boto3-9999.ebuild5
3 files changed, 73 insertions, 1 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 46d85dbbc035..115b608953e7 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,3 +8,4 @@ DIST boto3-1.23.5.tar.gz 501625 BLAKE2B 5a996b4dffd325ea2d6582450b027767ca9845e8
DIST boto3-1.23.6.tar.gz 502243 BLAKE2B d5b20d24d76df16669de25bdd9486766e4c4983f2619b9690a1bb318172d3343ae67cc9746438964817c60b1a2e7b3cb530f0dc54e15c13fe14c8cd1a566875b SHA512 3f940e394a15d10593b23ad67ffa16c9a45bbc5d6231b9ae621f90af3bc3497173f309191af7f3d9c3d4ea0331109228853c08d3fed7a84226481a8d911837ed
DIST boto3-1.23.7.tar.gz 502686 BLAKE2B 10ca206d1b7add5f9c88c5c474af4b6b4ac6fe4e690fa6ed2d1b4fb833874dfc6901c5c693ba96d72ac5af72533362065e107bb43f225f74fa18e41b52832482 SHA512 2970bbbccda3a74c821ab8598dc24204f838a417ea06b7816d16dda828123725162287d0d6ff4c9c815678f365220d5cea16a25abf5b70a4512845d157ab4f75
DIST boto3-1.23.8.tar.gz 503306 BLAKE2B 98e0f2aafd0ead06ea9ca7593f211e04d1f9639d3703cc172becc5745858e10a3f7633da4cd3e7a6b8fa8ff84d471f76fb75e9ee4018532c485bd3bdcc2eb972 SHA512 87be75109df80d1ff29ce13b196630c0f43ee8443f35854afaa7a337f77511a42483176e7271d4988dc22c922a47cb2d2c67ddbf7fe9bde43e9cc1c341bdc756
+DIST boto3-1.23.9.gh.tar.gz 503767 BLAKE2B fcd4556331020c6db015fe1591344c5fc4ee80302ade3d3bfea7468a3d5c32075d3ceff6c951ab0fe2ff4ded8843abdb0b55f4338a86afccba34ef1a48d05c0f SHA512 1d9c3e7077136d5c8117d57c5df9c50ce16fc8d0aee322002fb0fec1edc5fbeaf7c1386de31f0b496a298cdaf79c3fc77ea5c0b549141a07bd057eee08a0f0f0
diff --git a/dev-python/boto3/boto3-1.23.9.ebuild b/dev-python/boto3/boto3-1.23.9.ebuild
new file mode 100644
index 000000000000..73f2eea33612
--- /dev/null
+++ b/dev-python/boto3/boto3-1.23.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/boto3/boto3-9999.ebuild b/dev-python/boto3/boto3-9999.ebuild
index 8b87bf9ae488..73f2eea33612 100644
--- a/dev-python/boto3/boto3-9999.ebuild
+++ b/dev-python/boto3/boto3-9999.ebuild
@@ -21,7 +21,10 @@ if [[ "${PV}" == "9999" ]]; then
inherit git-r3
BOTOCORE_PV=${PV}
else
- SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
# botocore is x.(y+3).z