summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-19 18:51:08 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-19 19:17:57 +0200
commitdde33344d1434f4bb7394b32c97ac2f35886a7b5 (patch)
tree3248bc5861d2ec2bc5a3ef7b1b6b504780cafc8d /dev-python/boto3
parentdev-python/botocore: Bump to 1.17.23 (diff)
downloadgentoo-dde33344d1434f4bb7394b32c97ac2f35886a7b5.tar.gz
gentoo-dde33344d1434f4bb7394b32c97ac2f35886a7b5.tar.bz2
gentoo-dde33344d1434f4bb7394b32c97ac2f35886a7b5.zip
dev-python/boto3: Bump to 1.14.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.14.23.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 6798f3a4bb8b..2ddac5a5db73 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,2 +1,3 @@
DIST boto3-1.13.26.tar.gz 296782 BLAKE2B 117bb18679fe3ae8c4feee1a5fb2d1df1923764bba3dce72040ccc802d10bb88263744a0491195f414761b6755353775a8a413a121a5a0fc42373a4e9b8aac1a SHA512 513ea4b39a5af4ae8e45f6b8b315a19d5184998fa881782bf2e6074aee36a709b51813fc9fe403bb8dbfb9b51ead50367af18f0918a1c88a37eab263ccddd11a
DIST boto3-1.14.20.tar.gz 299325 BLAKE2B e1105a2ba55d59dc4d9a73f40e3bc34c05ceda906963d162eeeac8542d234a85b01e2ed485069269e923e2697b33c3f8e77af474716d8b2fa2a2f3ecf4093168 SHA512 d8f281d41386754c3720eeade23bb7b3c2b74176b5e0a763c5f355ed44e52f651d76a10dcc947142f0438be7c983bfc26ec8d31a1b341f55149188e6e7d6d1d8
+DIST boto3-1.14.23.tar.gz 299581 BLAKE2B 57cbb3fbd9a84f334b5874ca96490cb0269bb79f3fd2b50d4c51efcfadaa41b2e11853266ba12544b77999fa85fefb0bdf84d924667c4092b3deb72f41e33a21 SHA512 263b2abf3c220d3fb3d7acf4cd87266c11d3dcd5d7ffcafb0aab128b1e324d6f99c44de8abfb621b153b5fc51b9823b6b79ea5c529f6c59c548c900015bcdb5e
diff --git a/dev-python/boto3/boto3-1.14.23.ebuild b/dev-python/boto3/boto3-1.14.23.ebuild
new file mode 100644
index 000000000000..bbe6631e26ee
--- /dev/null
+++ b/dev-python/boto3/boto3-1.14.23.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit tests/functional ||
+ die "test failed under ${EPYTHON}"
+}