summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-07 07:35:34 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-07 08:33:13 +0200
commiteb7f66790141e7331b71bcabe69b293c23405499 (patch)
tree874a99d84421ad3bfba113a2be64cf8853914a1a /dev-python/boto3
parentdev-python/botocore: Bump to 1.21.16 (diff)
downloadgentoo-eb7f66790141e7331b71bcabe69b293c23405499.tar.gz
gentoo-eb7f66790141e7331b71bcabe69b293c23405499.tar.bz2
gentoo-eb7f66790141e7331b71bcabe69b293c23405499.zip
dev-python/boto3: Bump to 1.18.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.16.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 743dd8b61076..b9e6e8210a61 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,6 +8,7 @@ DIST boto3-1.18.12.tar.gz 398935 BLAKE2B 87f8627459908e4ff4bfde7ca7d325a355635c8
DIST boto3-1.18.13.tar.gz 399893 BLAKE2B 3c3e79e2a8ea41a6bf88a2e73926d6e61c9844fe0d373126611e3023d98d9e6a64cf7b537726260ae70fd78fea32f19127d59ddac5d48489be231bfb2a51b693 SHA512 14987a472d5dd7eb254fa4fd4e931b43f36afc57b40676c0c2c2400bb24d7a31892d317b2da6d618311b5df91ee4a5c6cd4974ecf90971540c41b4d9632533ff
DIST boto3-1.18.14.tar.gz 400263 BLAKE2B 827cf91c151ec03c6bca44967b8b94a5a4f93510ddae67b74dfe17fa800d02d2b139f3a0ecf6958ce24350345dd1f6da3c8dd69d7a5b504fbe79a9e8b587a3c2 SHA512 c3c338868ce50976deea02b308d8f9afecfbeac725319b4379391af1f85a6665de2cb59b2cb19a05520f1ff09d5c31bdc06525bd05e5bd2fa499641c4308b240
DIST boto3-1.18.15.tar.gz 400374 BLAKE2B 2170319480578b9ac7b6c0da9e9a2f256ce907b8e53bc626bf26fd65f3336ec1974d6dd1917f601fe139e859f144fafd198b2578ffb9097508f09dd40cf82313 SHA512 f330d8249c9f5749770ba5809f3a4fb524f23fc0545b24182023a3b74f815608bdb9986b434d972a017aa7786b1319705e8702b041174275f84a0266bdb7b857
+DIST boto3-1.18.16.tar.gz 400837 BLAKE2B fd3f8118adb4bf83484d084e3d1d5fd3b593dce2a394e6bea35196823cb31e4ecb8649840a2c214aabf245db60cd9974cdb85ab2e79fd103a576d7a9e39f5a8b SHA512 3c967e0d2ccc47e83d47fa84c3ef88f9672d57f9a5d314ec8b7047887ca1bec17a8960ddf3e2ac4db38f947e7432449027cfc4dce3441617b4f18c92734d7b70
DIST boto3-1.18.2.tar.gz 393528 BLAKE2B 20424f9a8ff013d1d9724f741ad6754747de504fb961688f433eba74ce1d6df7e95d68c45be1e87df1532f99b2fa4d7e8b00671a8ae9a378a4df74764924cdaa SHA512 287a1f24f62fa83fd944632799540257b2f8d6cf3b5d6add57be60e4f49dafd685bb4fcceef37fe907edba00a7f2285d92bd8d381b03e45ac794b22fdcfe8783
DIST boto3-1.18.3.tar.gz 393645 BLAKE2B 4967ac751e9ff5a86f6f571961df31d82f6012ade28aa19a038399077bf5a1b968dfa1172995423890b79a2ede54e2c6f6c1937e8ccf21010f17a4d96928df62 SHA512 f9c42257f0925fffaeb1a36e4731dc54fee1836c249617444292991d043dbb9b58472f73a806981c9763b569cc7402b378f6e1e0102fe0f995a7754807f19b38
DIST boto3-1.18.4.tar.gz 394442 BLAKE2B e82726143b353b843e915ea78ea2e033077ee495b1d416866f5c231f8bd864372496736d266b2b848ed8afd3134bd865c507291fd2fbdd5cae00a92ce3c5e76d SHA512 b3ba1328476a1c642c6b813afc3879e904bc14da69e062156df0405b3da6d2a15a4a40602f24d0a067a83cc441ce5a5e353dacb84869b0fe24e9984c0dec719f
diff --git a/dev-python/boto3/boto3-1.18.16.ebuild b/dev-python/boto3/boto3-1.18.16.ebuild
new file mode 100644
index 000000000000..819e73691110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.16.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ ||
+ die "test failed under ${EPYTHON}"
+}