summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-01-24 14:14:38 -0600
committerAlex Brandt <alunduil@gentoo.org>2016-01-24 14:18:32 -0600
commit71d089f8959c281291ed80bb9b9428835bce5439 (patch)
tree6c4014bbf818f9e58b41c7b859b7259e9c063858 /dev-python/botocore/botocore-1.3.22.ebuild
parentapp-xemacs/ebuild-mode: Add upstream information to metadata. (diff)
downloadgentoo-71d089f8959c281291ed80bb9b9428835bce5439.tar.gz
gentoo-71d089f8959c281291ed80bb9b9428835bce5439.tar.bz2
gentoo-71d089f8959c281291ed80bb9b9428835bce5439.zip
dev-python/botocore: add version 1.3.22
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/botocore/botocore-1.3.22.ebuild')
-rw-r--r--dev-python/botocore/botocore-1.3.22.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/botocore/botocore-1.3.22.ebuild b/dev-python/botocore/botocore-1.3.22.ebuild
new file mode 100644
index 000000000000..44e0a6ae37a9
--- /dev/null
+++ b/dev-python/botocore/botocore-1.3.22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}