summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-08-06 09:22:17 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-08-06 09:26:24 -0500
commit02fc7a536b73006d02ef4e4ca53be18443171f26 (patch)
tree6a9e6e2fe8a763ace8973bd0af1d7850a85bbb10 /dev-python/botocore
parentdev-python/simpleeval: Version bump (diff)
downloadgentoo-02fc7a536b73006d02ef4e4ca53be18443171f26.tar.gz
gentoo-02fc7a536b73006d02ef4e4ca53be18443171f26.tar.bz2
gentoo-02fc7a536b73006d02ef4e4ca53be18443171f26.zip
dev-python/botocore: add version 1.4.41
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.4.41.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 30fdbdaf564c..ec50e3c6a292 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.3.22.tar.gz 2349601 SHA256 02a6d320b09179bc5dcbafd4be732d9431bfe
DIST botocore-1.4.34.tar.gz 2630600 SHA256 a649ab5f9d9ddaa235510f62939e874aa3e37677564319883337ef9e98b7e5a1 SHA512 e683bf6881f9339a7431a085be274124e362a1b8ab538ae0589f7c266b160078e991ac27b2e5e5321c26f008ab548298abb382bd2d5b927866263b60ba67bb8d WHIRLPOOL 8f2d5e1c729cdbfeea29c416fc114e2c3ef10c9f09aa4098176547e7c7b54e7e2dbd0818f1147f13532f375da96943e4f4f5886c1d2809910c8527493937d956
DIST botocore-1.4.37.tar.gz 2642647 SHA256 20dc1a0bf37019cac33e0f76d04a2831f2786cbee17f54da0e32a93caf86ef49 SHA512 033b7a03b9428cfeffaf0bd805a3ef94487b01b00aa9991eb11bba5a7e2a657c22e525b88f9879114ce170ca98a6727498b40879d6f899c1126dab81321eee47 WHIRLPOOL 0f00332660cd8f858b32f70a850f19b279494b31f70c2210da0c82c23a7ef10eeab904dcce087f382cc5cb284e802baf695601e2c3ab2caa53e19cb2b8873630
DIST botocore-1.4.39.tar.gz 2646675 SHA256 e8377e312fae3f67b4e1f336a58f412f2dc9ff02117bc4a1a91ef568e6299cbe SHA512 91069671a1187968c64552f6218af8d07fe54cbcfcb8ede06c2bd5b823acc672d36205425a5370dd235028153cceb768782ae1c82fe9dffcea50a596307e7a99 WHIRLPOOL fd219954147173861f985ea2044806910f4c60c4c4ced36123a140d40f98968df5292ba1eecba99a6e6e39e71623dfa08630de46532237b503b09ac9d775f778
+DIST botocore-1.4.41.tar.gz 2655741 SHA256 da37c2b9c942ff280e47122e48e1e9af827c81191da919e9c434c69e455e6a30 SHA512 ae55eacc4410ac3d6a1588395e8f2e4b857d03f2956606d4a46c430c04b57997eaff8123c0e8546601cffaeabbb3aaaec99439bd1ffa57a114fe34cb56b1a609 WHIRLPOOL b875787ce674634056ff180291d5ebc14c3d99131eff9353f7f129137224d4d6bcd86f5e8f475ade7e91e62a6498adfb2eaa5ea5c058cc8556cd554737fefc68
diff --git a/dev-python/botocore/botocore-1.4.41.ebuild b/dev-python/botocore/botocore-1.4.41.ebuild
new file mode 100644
index 000000000000..9c57e3342b4c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.4.41.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}