summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-10-30 15:42:14 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-10-30 15:42:14 -0500
commit032e39d296fe886c30b2e20af9057015e479f4e8 (patch)
tree265828df5a863ea73ee64ff7be2de44cff466a29 /dev-python/botocore
parentdev-python/docker-py: add version 1.10.4 (diff)
downloadgentoo-032e39d296fe886c30b2e20af9057015e479f4e8.tar.gz
gentoo-032e39d296fe886c30b2e20af9057015e479f4e8.tar.bz2
gentoo-032e39d296fe886c30b2e20af9057015e479f4e8.zip
dev-python/botocore: add version 1.4.65
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.4.65.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 58ad14c6eaf0..1488f82aff3a 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.4.58.tar.gz 2906349 SHA256 a464bb803faffdd689c732768e472da8732b87795bc03ed4342a2ab99338e9f7 SHA512 717b02eef844ac192704c0eda2c2942358d714d92012dff59a38e0bb558ef3cfe6208f3892bb25b3752af96cc81ce057f4052783f60221e63bd087bba59a3dfb WHIRLPOOL bc7b077ca015103d12423f258f21eb42cdeecde311ec726268cb00a6ffd7126047efbdb5fac609f1ae77744465c9989b1d34f953b7d690657d5f8f5f83ccd38e
DIST botocore-1.4.60.tar.gz 2908934 SHA256 b091e12a6bba367f147631d3fdc4891567d260f79a09bce8a76f15647da0a2bf SHA512 77fb9e20d54455e1a200ef53db64491383e361f318ce903350beb13ce81edc438dc75642afa3c6825a1c5d3d517bd456ce362a7c917a6c725b2fe3638007858f WHIRLPOOL 17dd5a81f8ac8da7b62cfa91b2c202c6360eac760ebb9ed85b8633f4b7cb740bd5178df126052e36b142e48f47f0c1e749e1ed8d2684238df19ac22de643096e
DIST botocore-1.4.62.tar.gz 2912358 SHA256 9286305627019c6ecba580085046ed9ad5b26a4abdb095da1174258f39fdacff SHA512 bdef1da605541831592c25ccd99fb42e2bbf0a713cce650dcc8bfc04df816af88eaa56875fbb06d2f6efb8cf7b42cadc67cae566e892653e897d2e2625d5ea97 WHIRLPOOL 7486ba04ef97829456f0456a80d483a8c3dcfbfcc4f39659d1217ed649f2d2c180e7b37ed1c582d8347baf66d99b028dfa55824a305e21f783d99f8aabf95819
+DIST botocore-1.4.65.tar.gz 2946032 SHA256 9b4e2d54ad89294e3866888b9711b58ad9923a7850e2ad3245a96e5bf5ec9e6d SHA512 ee3cf9c8b6fd0d6adb7f423c2a72a2d5ac2e7efd314c07c2d5014580b700f26bacb6bc09a75a295b5d508234446640cfed641d39515a8d658ba8c35df3240358 WHIRLPOOL b49274619ec8f06d94e07592e4ba21a83f39241d4aa28c61ef514ec95993ec9769661470ace44778738fd72644fb96954fd3f67077e2ff467643352a5598e311
diff --git a/dev-python/botocore/botocore-1.4.65.ebuild b/dev-python/botocore/botocore-1.4.65.ebuild
new file mode 100644
index 000000000000..9c57e3342b4c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.4.65.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}