summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-17 18:51:34 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-10-17 18:51:34 +0200
commit18f09d189219004cb75b37fb4b35457816dc38cb (patch)
tree40b9bcfa22924646243c4dc6028268b6771fee59 /dev-python/botocore
parentprofiles: Mask x11-base/xorg-proto-2019.2 for testing (diff)
downloadgentoo-18f09d189219004cb75b37fb4b35457816dc38cb.tar.gz
gentoo-18f09d189219004cb75b37fb4b35457816dc38cb.tar.bz2
gentoo-18f09d189219004cb75b37fb4b35457816dc38cb.zip
dev-python/botocore: bump to v1.12.251
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.12.251.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 3602b3d53c25..036ac091254e 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,5 +2,6 @@ DIST botocore-1.12.122.tar.gz 5492931 BLAKE2B 05371245cd0de404713f920d0651f9bbdc
DIST botocore-1.12.205.tar.gz 5794632 BLAKE2B dfa0813ee1cd4d6d699fc27f2777da95b1719779bbb84f3d7d61da5c85b76c79286acfe304c598bade8d5320088070d1d69d99689f32f6efb05f04ffa66492ac SHA512 53d3770d8b771f3bbedbc0d6046cebec0b3961550c38ec29be4dd2b8c5f4da0150e70417f2070131746ab5c0df40ebce4ef6a1a2d6de0ce8d03e9928dbeeb594
DIST botocore-1.12.210.tar.gz 5859196 BLAKE2B 4ce448ea4bbf5bc21b84395188a7236a0d9f18c87c98fa3269185a2d947dd84f78cfa43b1806f51783f6009e1cbfba2d8833b5e3e6633eb3c4185dfd5ffaab77 SHA512 85e0679597935ed13ddd85997156a424df5b32bed1c96c65f89cc9eafd653015f87f261a042574bd8773dc46c76fb38da4bbddb031f20226fdab708c2438b1ce
DIST botocore-1.12.223.tar.gz 5892788 BLAKE2B 32a25636c7e3882e567daefeb0945863dd1b3c096d0c8459bec1814a371b455347ca7dbf21d8fffa5f3edb75fade36bd1dd25d86c23e2a01a3b465f769f53dde SHA512 1dde1fa483f9227f1048bf3e28bbb67687016d61a61781808dfdfb36b6024d680581423b5240d513c9d96e24fa94a762feb1aa44ef92bbb916974dbcf7c3127a
+DIST botocore-1.12.251.tar.gz 5936418 BLAKE2B a665d8a4c22bde4e5968b845e6df072a3ed2ce53561e007f2eaae144a91a77a32566c3c7f7a0158136b3e6d67aacffd5b77eed5fab51fe60fdfa29eb93e918ce SHA512 b29930367c602d40a7ce2386070dbaf83f34ea9321c7da40bf76ad7dae0587258fa2b3a058d17932d3e5fa22248c3ea5c838716fec5dce8da49e851b5c4f88d9
DIST botocore-1.12.4.tar.gz 4800384 BLAKE2B 121019d3c33872fdd874ddba36ecc8612a6354068ce7b759cbe7f35a9787e84c34d3a71ef3fdd2d721d3c3973a7600e4398cb7cd2a3ba698464c15137845bdf3 SHA512 8d196984f5623df403a8a23a9b7e7061e59c0ca56103f89d749d6ad7d92168ccae267f85312f2949cee322776d7948f1ecfda3d9d2783e8ba92fde7a178e8cac
DIST botocore-1.12.81.tar.gz 5383717 BLAKE2B 0bafd6038cf4a5d1fa4f0597024b09eca48ab95d071cccd09b1910ccf839719114166fab7d78bd2b30dec4b4993a0751d9504260636174df5f76f02495e79960 SHA512 d3be22af53a8c6dd55be3fa0b84a55cdce22d30d6e6f04b0bb69539b8107c86de6b5494079e3af40f9b5285ef10c21e69c85295e5cd7c6dc5ab5be91718a2ea9
diff --git a/dev-python/botocore/botocore-1.12.251.ebuild b/dev-python/botocore/botocore-1.12.251.ebuild
new file mode 100644
index 000000000000..a5470f903162
--- /dev/null
+++ b/dev-python/botocore/botocore-1.12.251.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ <dev-python/docutils-0.16[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}