summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2017-11-03 21:28:20 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2017-11-05 00:52:15 +0000
commit35a65f9f4ce292ff9a8a8a6c2718a67b5cce593e (patch)
treea66911199d181c1fc96855c415c90fbb02213bad /dev-python/botocore
parentdev-python/botocore: add 1.6.8 ebuild (diff)
downloadgentoo-35a65f9f4ce292ff9a8a8a6c2718a67b5cce593e.tar.gz
gentoo-35a65f9f4ce292ff9a8a8a6c2718a67b5cce593e.tar.bz2
gentoo-35a65f9f4ce292ff9a8a8a6c2718a67b5cce593e.zip
dev-python/botocore: add 1.7.39 ebuild
This is currently the latest upstream release. Ebuild copied from 1.5.90 with stable keywords downgraded to testing. Acked-by: Alex Brandt <alunduil@gentoo.org> Package-Manager: Portage-2.3.12, Repoman-2.3.3
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.7.39.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 9a1f8dc9d573..70446d41c44c 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.5.52.tar.gz 3606403 SHA256 bd232581d8720f87d49d14c134b2f563dbb7c
DIST botocore-1.5.90.tar.gz 3707524 SHA256 675f894c0ba91c8bb94be6954a40272e8c9d1ac9ddab2bee33acb1576fcaaedd SHA512 2a241c29c4874f632932f453954ca15469087b467ed36453db05fa219e81b6aa924aca672f01747de071091ffe6d55fa731ec124f7b47783176c79cf141dc82d WHIRLPOOL d42ec9a4d167d31edd9e65ee6a2cfa65c1ed80d8260f3fbe2fafe2e66f28d0d28f363f0b311e275589b065d2d43151381090b16d61e13aba1d4f4dac487cca35
DIST botocore-1.5.95.tar.gz 3712795 SHA256 26917b37fe993dc23dd1eb69c3208500fd057dc8b2e18b7c97bb26ae08ce7aa8 SHA512 872fac30476e3f05fa065ea2963b2221046d0eb7cd91267b0f9209fcd05b81b29eba99c439ad220a81c98a880b4087d961667d8a27c560cd9ba4481b8bc703c9 WHIRLPOOL cff1d6eb9c8a1d42c639da312500d1c23fae2c4c90afbd06c96345a20d6b3ef3f439f9d13f56962d208c4f6ae52fc27e3b48dcf276475e1933209ac5c9b8c0c4
DIST botocore-1.6.8.tar.gz 3769332 SHA256 2e679f2327b1064dc74b5a62ce71a725add031b8e539668ce666da3a857a1b63 SHA512 2565127620793eb94ef817a4295af3484aa7f30268fa915d37b82c5dc240ae2d74eea60bf68bdaf3d180648ff4225455e9453d75454d5a6d5ffadd19f2a2bd05 WHIRLPOOL 28f10e78fe29e6cec7e40ab837b4b49ce2b53d2d40788877da37a0f31ca89401e04a31d9341a8a48993634f413ebcf8d7655a34faf67f63984767cca172c245c
+DIST botocore-1.7.39.tar.gz 3838231 SHA256 28168c86cdb8847eaa0d53551ce9cbcac83f0d59d225c4281f43515b7dd1980d SHA512 0a6031315356f43e00ba5661020890478a589f0524bacd22fd24a9f8da147761f70d7b7fae9aab887301e78a392bc12dc7067174af9a07aac346d11a4cec9a22 WHIRLPOOL f3fc9a47b413e869b6cdba94cbf2ce99f2d39259a23e7aada6b2cbbe4a1f95e1136cd4cbf27b3d541c9edd383b53a88d44aeea6b92f9bedaefb71287b75a0754
diff --git a/dev-python/botocore/botocore-1.7.39.ebuild b/dev-python/botocore/botocore-1.7.39.ebuild
new file mode 100644
index 000000000000..f970e09103e6
--- /dev/null
+++ b/dev-python/botocore/botocore-1.7.39.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ ~dev-python/mock-1.3.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -v tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}