summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-26 02:58:29 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-26 04:04:52 +0200
commit35f212702bc0811728afa1cfc1c022f3303aa2c5 (patch)
treefa84451fd3bd089e6219e915542f2ffbc2c00d2b /dev-python/botocore
parentdev-python/black: Bump to 24.4.2 (diff)
downloadgentoo-35f212702bc0811728afa1cfc1c022f3303aa2c5.tar.gz
gentoo-35f212702bc0811728afa1cfc1c022f3303aa2c5.tar.bz2
gentoo-35f212702bc0811728afa1cfc1c022f3303aa2c5.zip
dev-python/botocore: Bump to 1.34.92
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.92.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index d7609df3f1ed..1d0b5e0be626 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.34.88.gh.tar.gz 12931548 BLAKE2B b3cc4c44ec0fa93798e842226487f29
DIST botocore-1.34.89.gh.tar.gz 12942425 BLAKE2B f2df9f8e1c90a55ec9c4a1695dd9d9eb4851d77d9f8a56f34df0ef34aaf580c655be726f3fb4ae3f63c7d69d73a4b3af5329f742229422712f191ddf6f028cf7 SHA512 35bdb67111d811a3b61ec23605fdca9607029102ab4873575c2901cc1075d441a27d72131365c3bc1b6fccf75336c99911f7dbe3def46a1ff4d3839fbe3f24f6
DIST botocore-1.34.90.gh.tar.gz 12959004 BLAKE2B e80aa5ec0727db538ccbdac357431a3015494aa10da2d4a0e9ff6fb5080eaab38494933c3d3678fbf9d1266007a5edfc742b5a65a6be8e26edb8e3e11de255b5 SHA512 a6eb45e36ff189edf7915667719112279a07133ce7ef9bfe94c18c8e5ab6df4b734a00d973986f9f74ed7e475fa72461457a7633464973e720f38cf828f2ecc8
DIST botocore-1.34.91.gh.tar.gz 12975028 BLAKE2B 0a4d4ca5530411148e7df7be4f937741457e44b3cf7774ded834db58ce9d6fd05f0fed6aaac1283ee410b6914d4825387c36545b17b1e78cf89175d560445071 SHA512 aad3f747ca49f58eed1116c303202e29bb0cec0a9816c5436bf75881d46b4c363e9aebbc039b3f6c6faedaf81cbea03d635b744fffb9f740cdb4c1d3ff21724f
+DIST botocore-1.34.92.gh.tar.gz 12978936 BLAKE2B 64fda2f4b1cbaa31c3d9148039c0db44e54811245186abf014ce1f3a635cb52f5bcef1180f082fed27300314ebd3b79887f364698b4df131f6534dc3bd694444 SHA512 4923a04ac00d325f7d8b3dd69b11d82130abf642afd5a7abb22620062ff9f8859940d9dea1ff15bc3ace546e7b85ddb0e56a30e472ee8adf4406124c9587fe09
diff --git a/dev-python/botocore/botocore-1.34.92.ebuild b/dev-python/botocore/botocore-1.34.92.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.92.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}