summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-09 09:43:10 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-09 11:20:46 +0100
commit68acd850ec1dd1ed61994f8410609e86de5ac6df (patch)
tree65f03fa0c7f270d437ecaf1714f74521a058fa68 /dev-python/botocore
parentdev-python/s3transfer: Fix for unbundled six from botocore (diff)
downloadgentoo-68acd850ec1dd1ed61994f8410609e86de5ac6df.tar.gz
gentoo-68acd850ec1dd1ed61994f8410609e86de5ac6df.tar.bz2
gentoo-68acd850ec1dd1ed61994f8410609e86de5ac6df.zip
dev-python/botocore: Bump to 1.23.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.23.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 454328e076b1..edab36924b57 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.21.60.tar.gz 8253381 BLAKE2B f035a335f8d72c182f6fbd3f2216608bd56
DIST botocore-1.21.65.tar.gz 8261668 BLAKE2B c955019d06aa1b2f4503673b7d9009e5d6e07ee4348e730e6b4d11285f3030f676f0efda58a72dd92cac8c6ba0cb57f8f879eb5298009ecbd227904d18a453bf SHA512 955d24d2d486524af7bee57a56e2e903458030420198f3e6ab49d61be52b812a98444a9d0f86503b121270d6642345ffad6053ad143374dc56ab908b385afb0a
DIST botocore-1.22.12.tar.gz 8343683 BLAKE2B df7b2c86f226df14dc8181e8506acc7dd660797311049e2342ec721e853af1158c845749a8143ec6677601420ce6140173da8df5d9e4550cdf9becfc944ebd3c SHA512 0ab78902711960f8373a91af379b4981ab29646cc9f94e49836deaa432695c503879ed0bbbf54e3641e50933b5ed658e48052ca2b8b8391f705284d9abd24c1f
DIST botocore-1.22.5.tar.gz 8301083 BLAKE2B 91f9d38e7c5bcb0b8f58c04547ad45489f58d2240c6b7301cf632969a4a73cf4a1d51c8c68c8def27653c10041d2163ad7ca800dcf6fd07972b506bf2566cae3 SHA512 710a9eeee03dc79ca4ffacc4974f09ca769e1e3b8cb143f6f0349240dd8c2af8ee526a1dadb7310a26019363f683fc4149cb4c73d8b94a856a384fab7f84fb5c
+DIST botocore-1.23.1.tar.gz 8353252 BLAKE2B e29dc3a2112c24f244d25336964605ba14a07f9db3f0462db911f9a1009846dc3601ae27bad05e8e58161e911a20ecbaf1f280bd61204a7392906f0553dcec64 SHA512 6938f54a98474aa0bb3c73249f81bc68cb364d381af3f08ac698d66b9f03c2b3649a253bafb57a6f525757f459a8c3da775370f64984be4bca0f2d4310f7a367
diff --git a/dev-python/botocore/botocore-1.23.1.ebuild b/dev-python/botocore/botocore-1.23.1.ebuild
new file mode 100644
index 000000000000..7337877443c9
--- /dev/null
+++ b/dev-python/botocore/botocore-1.23.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit}
+}