summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-22 10:11:25 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-22 12:28:03 +0200
commit716a96244dda01dbdebfbf3d76fe85b3618e48ff (patch)
tree0abf95dbbce10c352ac0d1c7afde80ca9d97f836 /dev-python/botocore
parentdev-python/prompt_toolkit: Bump to 3.0.21 (diff)
downloadgentoo-716a96244dda01dbdebfbf3d76fe85b3618e48ff.tar.gz
gentoo-716a96244dda01dbdebfbf3d76fe85b3618e48ff.tar.bz2
gentoo-716a96244dda01dbdebfbf3d76fe85b3618e48ff.zip
dev-python/botocore: Bump to 1.22.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.22.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5fa124c5d88f..f774d851cd44 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.21.63.tar.gz 8256427 BLAKE2B 7b6a4d29005cdf127881a88b51ffb316269
DIST botocore-1.21.64.tar.gz 8258628 BLAKE2B 5a335085224ed86eb2364a67198f1fe8d745102e38ed3cab47821d5bd03c6163ccd7754fc2201384d16d28c9aaf2c0ad447f97374e1b6414739688c788b3b122 SHA512 f40aca854103d97f8d36d178cd5a8fc19e1bde63476c570ae357f2526a82054c3e26a4db26a996df23d66a09bb4ef9354372010b726499cce0021d2dd48c7bb6
DIST botocore-1.21.65.tar.gz 8261668 BLAKE2B c955019d06aa1b2f4503673b7d9009e5d6e07ee4348e730e6b4d11285f3030f676f0efda58a72dd92cac8c6ba0cb57f8f879eb5298009ecbd227904d18a453bf SHA512 955d24d2d486524af7bee57a56e2e903458030420198f3e6ab49d61be52b812a98444a9d0f86503b121270d6642345ffad6053ad143374dc56ab908b385afb0a
DIST botocore-1.22.0.tar.gz 8275754 BLAKE2B f0acbccf0c451f6cdd75495c15140c8c65bad567ab9f43c0cf77de8b1736689865688816f3b60ab697552f872f7027d26046050828dc0ad7666d5567b3b613ae SHA512 7f39cb16573d9ae4649ad67bb402f2d2fbd371f8818ec2573f7826e71828c559e37e6759e2c6ab8a05d6fa97ce53bac0a94f6d30dea0c184a079e97d1fba3597
+DIST botocore-1.22.1.tar.gz 8276879 BLAKE2B 91b339fa62d5faf808273c26187d86e1c855b140a22d348d04b95a21be47e2d83081d25e97efb1f7fae899a8abb98311250062e43e998199aff90486c154b178 SHA512 95ac5c5a0ff4cc31cd4fc0973cef45c5a6bce5b82091bde2f2c0cd8215c65c11be6d4fc62ef76110287e01dc54eb9b69e5bda0f2ce39b728d36097834afd47ac
diff --git a/dev-python/botocore/botocore-1.22.1.ebuild b/dev-python/botocore/botocore-1.22.1.ebuild
new file mode 100644
index 000000000000..638620b2cbc8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.22.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}