summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-01-16 15:05:59 -0600
committerAlex Brandt <alunduil@gentoo.org>2016-01-16 15:10:25 -0600
commit7389fb7b8b93e665bfc336e775ddeb309ca082cc (patch)
tree61383ab29de2768ecd342ec41c05b64b7778427c /dev-python/botocore
parentdev-perl/File-MimeInfo: Remove old (diff)
downloadgentoo-7389fb7b8b93e665bfc336e775ddeb309ca082cc.tar.gz
gentoo-7389fb7b8b93e665bfc336e775ddeb309ca082cc.tar.bz2
gentoo-7389fb7b8b93e665bfc336e775ddeb309ca082cc.zip
dev-python/botocore: add version 1.3.20
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.3.20.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f882b65b9cf6..b979307ae7e8 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST 1.1.11.tar.gz 1975224 SHA256 b4e6edc12177dd4f720259aa7027bab00fb9db2029e40e
DIST botocore-1.2.10.tar.gz 2202147 SHA256 8541895aa2abe2183fa15efe33794db7428fec3302e0c9bf1db13fa1668e2b66 SHA512 5395776f50c5302d2fa75af702ced17da66a4c0435d62aed907f1ceaa93d38acc2d91a250d2153d852239a08d9f7f0bf361523cc89168a6cb81ef6f8a6ec5124 WHIRLPOOL aa4ff7a2aa1a900642782783b85479943bcce85c7df0c056d989d329c0693424110859a1d9d358e0cc5af94be174c96786c2f339e78934c114011606dfce11ec
DIST botocore-1.3.14.tar.gz 2289202 SHA256 44904496f26370f47469327e5df10e439aa07aaf1c0516c7c67352337eeeb729 SHA512 7cf1a342271b02842c5d989fa4ac2bb02074f8ff18dda70c751857f44b83e2ce02c904f0484a05f274bcb9459bf580e0456b72554e87509b2f2529170a239362 WHIRLPOOL efa0d700bdd7e9803be63fc3a54fffb4234356769b1dea69bf93c974deb9a3a3438d88de004dce6a0c83390042fb8f2b822d9204f6727eceb5aee657c22c6a98
DIST botocore-1.3.2.tar.gz 2243332 SHA256 af8176c95244bd9195afb4cf2a2c21a605e884cf6886889c6d983d2adda844ad SHA512 e68288c0f9aae3e30814df3a5562e503d6affc238d74f2a2c8c7e1796f3a1d49bf3408befd9aeb8753d81944118cff7af61ba7db57881f51ca07378fd0d1ec4d WHIRLPOOL adfdef5696e2f3d95626f2b474fe616db5a3874bbfdacb33ed69260dc66c9c62c86016fe9f102272ef012d1b0ec64a1ebe9f0502830c6648be959cf1b8fd7739
+DIST botocore-1.3.20.tar.gz 2326244 SHA256 9760d883611110a05f5f8346c7b2198aef87be9117d4cbe1e4ee6608a560c4a2 SHA512 bd8d80598631610da4f05c8cc735affef31c726dc30512e358950e967efefbe63455bc63dccbb180f059a3f9da6c0004edfafc9bf99198732708c1ef141f0b06 WHIRLPOOL 18ba18fa6d62b10d7547f58bf6e8d26cab8564f4e8a229dd6f939db6b4f4d05edda4a239811067443d14edcfe2b293acdb449fc809f551f99b4ff37e4fb70fbd
diff --git a/dev-python/botocore/botocore-1.3.20.ebuild b/dev-python/botocore/botocore-1.3.20.ebuild
new file mode 100644
index 000000000000..44e0a6ae37a9
--- /dev/null
+++ b/dev-python/botocore/botocore-1.3.20.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}