summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-08-16 17:27:04 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-08-16 17:31:19 -0500
commit73f8fa70d5fafcf5809bc9b597e2f072d673f376 (patch)
tree6c0e3dc45a58b25b2c853ef178813ffcf63b2399 /dev-python/botocore
parentdev-haskell/haskell-src-meta: amd64 stable wrt bug #554026 (diff)
downloadgentoo-73f8fa70d5fafcf5809bc9b597e2f072d673f376.tar.gz
gentoo-73f8fa70d5fafcf5809bc9b597e2f072d673f376.tar.bz2
gentoo-73f8fa70d5fafcf5809bc9b597e2f072d673f376.zip
dev-python/botocore: add version 1.1.8
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.1.8.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5ade8b8b08da..1e0b73d6ce19 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.1.3.tar.gz 1951206 SHA256 1cb1ed85a46090030bebda39487e31baa44effdee78b862d2b828ad7eb70181c SHA512 cd5d5c980a5fa4b7aa4da29dfd174c65f8d6e6aa584944154666287d9c1ce74eed177fceb2e26aa7600ed11a4f2e3f66889b8e65d4816d4887e042bb0ec877df WHIRLPOOL 70a4a4ebf7ce9fc5d1740a984700b9d28149a7d65d6fa72fd197d2bcc85f1621609ae06cc332a334a044be70b14c6f63071a5008a35b2a2d7ba361e112da3af3
DIST botocore-1.1.5.tar.gz 1963111 SHA256 4aac2f5c46c37fac047e3f668692882c306963c679a69aacfc07e4c70d5ce70d SHA512 0d609ab8249a44e013296ec30fe6856d62e9453e9e1fa8e39e32b4768af8dffdb439c9b8249964d230090d483e36cfe94bf87b1261a991e3abc3b60b982c61b7 WHIRLPOOL 84f7ac82f03297bd196d0fb2fb77eb870b933ced252a9d56981ccbbd115243f94e17662203c4fce9d2a9aa700f0013754cc57b34db2f3312e4169e2eb801277a
DIST botocore-1.1.7.tar.gz 1966396 SHA256 50d90705815aff4dd4e2be503ad42c0fb52874053046de9042bc16563a8ecd68 SHA512 4aba7712b7154362a52f46e2c0d28d0ff0d096d7741e99760848a23338420be290b3b91892cb764f4aca21122b208533a5b1e33bf23bce76b09e0bb5560b6764 WHIRLPOOL 9871171175dd88bf69171966c3fe8c410f07b0340381d64925d7c7ccf108664ba97f9785ffd61e3518ff9ce834eee7c405420d37c071acb1c655dd8c38f2ae95
+DIST botocore-1.1.8.tar.gz 1969137 SHA256 338fed0119d819a60b2b7cf1a1a38f93603c5f012a2a483b713425816a43a57c SHA512 24c17057ce600873fb37ecd6712defe8339a36cc11cb77afd2417b68bef63e46ebb22dbe320e5c4bb7f948aee6fb3fc90336c021c6adf2d7902cab8ce6d214f2 WHIRLPOOL 54872902565ad7af5932517a554a4577445aa2539c1668f5d672f7e60b84efae6ad0af68e98d9cc3ed2fb4204936c6881bf17cda0ef821a2ee6e8f60b1cf6b20
diff --git a/dev-python/botocore/botocore-1.1.8.ebuild b/dev-python/botocore/botocore-1.1.8.ebuild
new file mode 100644
index 000000000000..a9e058563f4a
--- /dev/null
+++ b/dev-python/botocore/botocore-1.1.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ ~dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}