summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-03 04:39:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-03 05:28:36 +0200
commit7a55041b4cabd1c45bb3836d5c7e4b82562e2a16 (patch)
treed65b903c95fc79c7bf54da6337adde17d015a598 /dev-python/botocore
parentxorg-3.eclass: conditionalize autotools deps on XORG_EAUTORECONF (diff)
downloadgentoo-7a55041b4cabd1c45bb3836d5c7e4b82562e2a16.tar.gz
gentoo-7a55041b4cabd1c45bb3836d5c7e4b82562e2a16.tar.bz2
gentoo-7a55041b4cabd1c45bb3836d5c7e4b82562e2a16.zip
dev-python/botocore: Bump to 1.34.97
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.97.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index e2367a16cdb2..7aab18ef20dc 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.34.93.gh.tar.gz 12982900 BLAKE2B 3225279b85101e04da3be11f01ac3f4
DIST botocore-1.34.94.gh.tar.gz 12986670 BLAKE2B 27299e44f2acf9d51c056c3612f60dbb11bacd8411272238fe8ac1c89acd84c1a70594877139a71e2892c152b9902456ed0f9868f82e95366871904aea4d757a SHA512 24b4b5e9a2009a3bc9e14ed04aeb3d7d51c3073b38e1b33f95892ec3bacc94562e1b8c69cf17fff38c4a979d2958cc3a88e9be66e098fcb8f67765d22543e75d
DIST botocore-1.34.95.gh.tar.gz 12998063 BLAKE2B 2616d558d82f022393cf267f9131644310d5a406bfcd9374c52640d998671af40d0407a7e23d21f7571dbdb293a44886760059b770f2b589931be476971c9fff SHA512 b2be04b61d27c30b690f5c6e5504670938bd5d2f13ae6e194ecc77b2b15092726f07a7abf0165fad304c919652c36e9defd8383448a6ce916e995327cd145d7f
DIST botocore-1.34.96.gh.tar.gz 12998705 BLAKE2B 5266f479e50b24cdf611634c4d129327dd14cbd08c676fb54861e775e1ba6a767e43c7901a7374602b30a3066eba77a7616e7ff4f0224c1f735f413876ee956a SHA512 174b604d5e80dd211ca9cd1ae3f2635a4c8c6c6b7398943e8d539b960468a79a1c641367a3daee75689f948d37d054b25e3f36d0fd6137545ecda823d0c50606
+DIST botocore-1.34.97.gh.tar.gz 13003082 BLAKE2B ac7104e1cc19ae63a7bb0bb2d16fcf88ea3e5174382556c27f25f3665b30cc2b22efd1d59f146448647926ecd259d38313bac76b000fc6a12c97958debf93cc6 SHA512 bf29fa82fdcf679d24b116516694da769ab3aaaebdcabddec121fe4ba564f718937c634d31306273af15da272a796aba75b0406cfe805f12512b3430ec071331
diff --git a/dev-python/botocore/botocore-1.34.97.ebuild b/dev-python/botocore/botocore-1.34.97.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.97.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}